Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-08-2015, 02:25 AM
mika mika is online now
Registered User
 
Join Date: 01-12-2015
Posts: 7
Editing large document _extremely_ slow

Using the latest UR trial version, I created a very small tree and into a text node I pasted a reasonably big but not huge document ~140kb

On my machine, a 4 years old 64bit dell laptop editing in this document is nearly impossible .. if i type at my normal speed which is not great I have to then stop and wait as the words slowly appear on the screen while the interface is locked. Totally painful. No other editor on my system is having any such issues and if this is normal performance then unfortunately UR is unusable for me.

Am I missing something ?

Thanks!
Reply With Quote
  #2  
Old 02-08-2015, 04:36 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,723
We also observe slow editing of large RTF documents, and it seems to be related to the spell checking component. If you extract and double-click DisableSpellChecker.reg in the attached .reg file, then download and install the latest build (UltraRecall.exe 5.1.0.11 in Help | About after installing), this problem should be resolved.
Attached Files
File Type: zip Reg.zip (558 Bytes, 397 views)
Reply With Quote
  #3  
Old 02-09-2015, 02:38 AM
mika mika is online now
Registered User
 
Join Date: 01-12-2015
Posts: 7
thx!

Tried it twice, closing UR, applying DisableSpellChecker.reg, starting UR again, but no difference.

I can see the spell checker still works (misspelled words marked in red) so I guess somehow the registry settings were not set properly ?

Please help
Reply With Quote
  #4  
Old 02-09-2015, 05:32 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,723
You also need to download and install the latest build from http://www.kinook.com/UR/download.html. It will show

UltraRecall.exe version 5.1.0.11

in Help | About after installing.
Reply With Quote
  #5  
Old 02-10-2015, 04:44 AM
mika mika is online now
Registered User
 
Join Date: 01-12-2015
Posts: 7
ok editing is normal speed now thanks

- For some reason updating UR made some of my documents read only, I can see the READ indicator on, pls tell how to make them editable again ?
I searched the help but no luck

- Do you think spell checking on big RTF will be fixed soon ? this is crucial for me (and probably many users)

- At the very least have an option to toggle spell check on and off easily from within UR so one can spell check after finishing working with the document
Reply With Quote
  #6  
Old 02-10-2015, 09:44 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,723
Regarding read-only documents, nothing else changed in the last build. Make sure that the document file extension is included at Tools | Options | Documents | File extensions to open stored documents writeable. For linked documents, make sure that Tools | Options | Documents | Allow internal editing of linked documents is checked. Otherwise, please send the info from
http://www.kinook.com/Forum/showthread.php?t=3038

In the latest build (5.1.0.12), we've added the ability to enable and disable the spell checker within UR (Tools | Quick Options | Enable Spell Checker).
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 03:25 PM.


Copyright 1999-2019 Kinook Software, Inc.