Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-08-2008, 01:19 AM
ambalboa ambalboa is online now
Registered User
 
Join Date: 06-25-2007
Location: Houston, TX
Posts: 70
Building solution with report server project and fails only in VBP, why?

I am having trouble building a VS2005 solution via VBP but I am able to build when using Visual Studio 2005. I am getting the following error output for the report server project that fails when building using VBP.

------ Rebuild All started: Project: Reports_VDOT, Configuration: Production ------
Error : Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
Error : Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
Error : Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
Error : Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
Error : Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
Build complete -- 5 errors, 0 warnings

However, when I open the solution on Visual Studio 2005, the project does not fail when I build it. Does anyone know why this is happening?

I set the configuration to match the same as shown in VS2005, that being, Release|Mixed Platforms. I try other types and more project failures occurs; this should be the one.

Please let me know if you need more info.
Reply With Quote
  #2  
Old 10-08-2008, 08:56 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
It is Visual Studio (msbuild/devenv) that actually performs the building of a VS 2005 solution (and is reporting the error), not VBP itself. And building a VS project from the command-line is not identical to building in the VS IDE. If building via MSBuild does not work, you might try using devenv (enter devenv in the Override field on the Options tab), as this will be closer to what the IDE does when building. Even then, we have heard of situations where building from the command-line doesn't work even when building in the IDE does. You can check the 'Display the compiler command-line' checkbox on the Options tab, rebuild the step, and provide the msbuild/devenv command to MS when submitting a support incident.
Reply With Quote
  #3  
Old 10-08-2008, 05:09 PM
ambalboa ambalboa is online now
Registered User
 
Join Date: 06-25-2007
Location: Houston, TX
Posts: 70
OK, I will ask for Microsoft's help.

Strange thing. I was building this same solution before and I was having problems building it until I wrote devenv on the Override field on the Options tab. Then it was building fine until recently.

Here is the command-line being created and used:

Rebuilding configuration 'Release|Mixed Platforms'...
Command: "C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\devenv.com" "C:\filepath\filename.sln" /rebuild "Release|Mixed Platforms"

Microsoft (R) Visual Studio Version 8.0.50727.42.
Copyright (C) Microsoft Corp 1984-2005. All rights reserved.

Thanks for your help and I'll let you know what I find out.
Reply With Quote
  #4  
Old 10-08-2008, 05:57 PM
ambalboa ambalboa is online now
Registered User
 
Join Date: 06-25-2007
Location: Houston, TX
Posts: 70
I've executed the command-line on the VS2005 command-prompt and the report server project fails, as it does in VBP.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:42 PM.


Copyright 1999-2019 Kinook Software, Inc.