Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-19-2010, 04:25 PM
ChrisF ChrisF is online now
Registered User
 
Join Date: 12-09-2009
Posts: 67
Does VBPro run *.exe files after building them, as a test?

I have a scenario happening in VBPro v7.2a that I can not reproduce when I do the same steps manually in Visual 2008.

I have a windows foo.exe dependent on bar.dll to run. I also generate a bar.lib file, and never delete the bar.lib file. foo.sln uses the bar.lib during compile time, and bar.dll during run time. (I did not set this up, and can't redo the setup).

I do these steps in VBPro.
- Clean foo.sln and bar.sln, which deletes all generated files except the bar.lib file I mentioned.
- Build foo.exe before building bar.dll

I get a message box that says "foo executable stopped working." or something like that. If I build bar.dll first, I do NOT get the error.

I do NOT get the error if I do these steps manually in VS2008.

I alleviate the issue if I do this in VBPro:
- Clean foo.sln and bar.sln, which deletes all generated files except the bar.lib file I mentioned.
- Build bar.dll
- Build foo.exe

Any clues?
Reply With Quote
  #2  
Old 05-19-2010, 04:57 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
http://www.kinook.com/Forum/showthre...?threadid=4500
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:17 PM.


Copyright 1999-2019 Kinook Software, Inc.