Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
  #16  
Old 01-02-2010, 10:48 PM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
In going through all .eml files/email messages in my URD I did manage to see at least one pattern: Links. All emails I previously imported to UR via the Thunderbird extension appear to have been converted to text format; emails that had live links in them now show all their links as text. However all the emails I have imported since installing Windows 7 that had links are imported with the links live and intact - and all of those open externally. On the other hand, any text-formatted emails I import now render fine in the MIME viewer.

I can't remember if the previous imported emails ever had live links in UR or if they were always imported as text. But that is the only pattern I have noticed during the last couple days, while locating every last email in my URD and testing them. Live links? External. All text? MIME viewer.

Let me know your thoughts on that.

Thank you.

Jim
Reply With Quote
  #17  
Old 01-04-2010, 07:48 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Ultra Recall always imports and stores the original message (.eml file). When using the MIME viewer to display an imported message, if the message contains a text part, it is displayed in the rich text editor; if the message doesn't contain a text part but does contain an HTML part, it is displayed using the internal browser (IE).

Apparently on your system, for messages containing only HTML, displaying the HTML part in embedded IE results in the message opening externally. Is the message body also displayed in UR, or only externally? Is the message displayed externally in Thunderbird, IE, or ? Please ZIP and post or send screen shots of 1) UR after selecting the message and 2) the external application displaying the message.

Thanks.
Reply With Quote
  #18  
Old 01-04-2010, 04:10 PM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
Thanks for the reply.

When the message opens externally the UR viewer/browser shows blank and the message opens in Thunderbird. BTW I am now back to using Thunderbird 2.

Email with zipped images is on the way.

Thank you.

Jim
Reply With Quote
  #19  
Old 01-04-2010, 04:42 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
That's really weird. I can't explain why it's doing that on your PC. The imported message you sent earlier displays fine here in UR.
Reply With Quote
  #20  
Old 01-04-2010, 04:52 PM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
Well, as I mentioned earlier, the only change in my system - though it is a big one - is that I upgraded this machine to Windows 7 from XP Pro. Oh, I also installed TB2 and then upgraded that to TB3, though I have since dropped back to TB2 again.

I haven't changed any other settings in UR itself. I am still using the same Anti-Virus, NOD32 from Eset, and I have UR excluded from the AV.

All else is as it was, and UR + TB2 were working so well together.

Not much else I can do here. I don't really know enough to start changing other settings in UR, plus I would think that you's tell me if there were any other settings I could try changing to help with this.

Maybe I will switch email clients - TB3 has really been a disappointment. I have Outlook messages that were previously imported into UR that don't show any text, though I'm sure that is because I no longer have Outlook installed. I don't want to pay to upgrade my Office 2003 - it's ridiculously expensive - so I installed Office 2007 Home and Student, which doesn't have Outlook.

I am thinking of trying Postbox. I tried that when it was in beta and it is pretty nice. Will Postbox work with UR?

Thank you.

Jim
Reply With Quote
  #21  
Old 01-04-2010, 05:19 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
I fired off an email to the Postbox vendor to see how much work it would be to convert our Thunderbird extension to work with Postbox. But that may not help -- most likely any HTML-only EML file that's imported into UR will have the same display problem on your system. I tested on Windows 7 with the UR config settings you provided on 12/21, so the problem doesn't seem to be in UR itself, but possibly some IE oddity.
Reply With Quote
  #22  
Old 01-04-2010, 06:08 PM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
Quote:
Originally posted by kinook
I fired off an email to the Postbox vendor to see how much work it would be to convert our Thunderbird extension to work with Postbox. But that may not help -- most likely any HTML-only EML file that's imported into UR will have the same display problem on your system. I tested on Windows 7 with the UR config settings you provided on 12/21, so the problem doesn't seem to be in UR itself, but possibly some IE oddity.
I just opened IE8 and reset the security to Medium - it was at the default Medium-High. Hasn't helped any.

Are there any particular settings in IE8 that could cause this? Any that you know of?

Thank you.

Jim
Reply With Quote
  #23  
Old 01-04-2010, 06:11 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Not that I'm aware of.
Reply With Quote
  #24  
Old 01-11-2010, 12:06 AM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
OK - I have finally solved most of the problem here!

I happened to import an email from Thunderbird 2 into another program and guess what? The emails would not render there either. Opened them externally in Thunderbird, just like UR. So I knew then absolutely that the problem didn't lie with UR at all.

Then I went to my File Type listing and found that .eml files were set to open with Thunderbird. I have no idea if that is how it was always set up - I have never changed that manually, in Windows 7 nor in XP Pro. So I deleted that reference and now while .eml files still carry the Thunderbird icon (I didn't change that), they no longer open in Thunderbird externally. All my .eml files in UR are now shown internally. Yay!

However there is still a small problem: all new emails imported into UR - and even those I dragged in from the file system that have never been touched by Thunderbird - show in the MIME viewer IF they are text only. But if they are HTML emails they show internally in what I guess is either the UR browser or the RTF viewer - I'm not sure how to tell the difference in UR. And the problem now is that all the header information and HTML code is loaded upfront with text and images following further down the page.

This doesn't appear to be true for emails imported from Thunderbird earlier, but for any that I either import with the extension or drag into the tree the MIME viewer is not used and I see all the coding and header info.

Any idea how to get the HTML messages into UR intact? Is it possible that I have to set some file type now to automatically use IE?

BTW, this must be new with Windows 7 Home Premium, as I never set or changed the .eml file type before. Either that or Thunderbird 3 - which I had installed earlier - did this.

I appreciate any further advice.

Thanks!

Jim
Reply With Quote
  #25  
Old 01-11-2010, 07:08 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Remove .eml from the Documents | MIME viewer option and add it to the Browser | File extensions option.
Reply With Quote
  #26  
Old 01-11-2010, 04:38 PM
J-Mac's Avatar
J-Mac J-Mac is online now
Registered User
 
Join Date: 06-25-2008
Location: PA, USA
Posts: 184
Quote:
Originally posted by kinook
Remove .eml from the Documents | MIME viewer option and add it to the Browser | File extensions option.
That's even worse. Now ALL emails show the full header ahead of the message, and HTML emails also show the header plus all HTML code which pretty much makes the emails unreadable.

Must still be a setting off somewhere, though I can't find it.

Jim
Reply With Quote
  #27  
Old 11-04-2010, 08:17 AM
Anne's Avatar
Anne Anne is online now
Registered User
 
Join Date: 08-26-2008
Location: Florida
Posts: 16
Can not view email in internal viewer

Quote:
Originally posted by J-Mac
Well, I don't know what I could have done to cause it to keep opening externally. Most are opening internally.

I also sent you screen caps of my UR Options for Browser, Document, and Editor; did you happen to see anything there that is out of line? They should be all default except for where I added the email file extensions to the MIME viewer.

Has anyone else seen this? If so, please let me know what you have done to try and fix it.

Thank you.

Jim
I am having the same problem with Thunderbird. I have tried all the same options and TB stil opens in external viewer. Anne
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 10:52 AM.


Copyright 1999-2019 Kinook Software, Inc.