Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-12-2008, 03:06 PM
Mcguirk Mcguirk is online now
Registered User
 
Join Date: 09-12-2008
Posts: 3
Problem overriding the Config Files Path

I am trying to override the Config Files Path on a Windows Server 2003 machine by setting the Registry entry described in this thread http://www.kinook.com/Forum/showthre...s=&threadid=36.

It works just fine on my Windows XP machine, but on our build machines, which run on Windows Server 2003, there is no SOFTWARE\Kinook Software\Visual Build Professional\ConfigFilesPath subkey under HKEY_LOCALMACHINE. And if I add the subkey it doesn't seem to work.

In the meantime I will use one of the other methods outlined in the other thread I linked, but I'm curious about what's going on there.
Reply With Quote
  #2  
Old 09-12-2008, 03:22 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
It actually needs to be a REG_SZ registry value, not a subkey. And that forum thread was a bit out of date -- with VBP v6, the registry value is

HKEY_LOCAL_MACHINE\SOFTWARE\Kinook Software\Visual Build Professional 6\ConfigFilesPath

(which works on Windows 2003 in our tests) rather than

HKEY_LOCAL_MACHINE\SOFTWARE\Kinook Software\Visual Build Professional\ConfigFilesPath
Reply With Quote
  #3  
Old 09-12-2008, 03:30 PM
Mcguirk Mcguirk is online now
Registered User
 
Join Date: 09-12-2008
Posts: 3
Sorry I forgot to mention I did put it a REG_SZ value and I did put it under HKEY_LOCAL_MACHINE\SOFTWARE\Kinook Software\Visual Build Professional 6\ConfigFilesPath

In your tests does your Windows Server 2003 machine have a HKEY_LOCAL_MACHINE\SOFTWARE\Kinook Software subkey at all?

Because I don't. I only have "Kinook Software" showing up under HKEY_CURRENTUSER. I had to add it into LocalMachine manually (with no sucess).
Reply With Quote
  #4  
Old 09-12-2008, 03:47 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
You're probably running 64-bit Windows. If so, either run the 32-bit RegEdit.exe at

C:\Windows\SystemWOW64\regedit.exe

or access the 32-bit registry via 64-bit RegEdit.exe at

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Kinook Software\Visual Build Professional 6
Reply With Quote
  #5  
Old 09-12-2008, 03:48 PM
Mcguirk Mcguirk is online now
Registered User
 
Join Date: 09-12-2008
Posts: 3
Hah! Indeed I am running 64 bit. Thanks!
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 09:38 PM.


Copyright 1999-2019 Kinook Software, Inc.