Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-04-2006, 12:59 PM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Problems with Copy to UR

Whether I use the UR toolbar button in IE, or whether I drag and drop the icon next to the URL, Copy to UR doesn't work properly. Please see the attachment for a couple of GIFs--one shows what I see in IE, the other shows the copy in UR.

Do I have some setting wrong or something?

Thanks,
Attached Files
File Type: zip sample copy to ur.zip (159.7 KB, 688 views)
Reply With Quote
  #2  
Old 07-04-2006, 05:14 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
To capture pages from a logged-in session in a browser, select part or all (Ctrl+A) of the web page and drag/copy that into UR instead of the URL icon.
Reply With Quote
  #3  
Old 07-04-2006, 09:50 PM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Attached is what I got when I followed the procedure you suggested.
Attached Files
File Type: zip from ur.zip (128.9 KB, 637 views)
Reply With Quote
  #4  
Old 07-05-2006, 07:36 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Strangely, that actually is the HTML format that IE puts on the clipboard for that page.
Reply With Quote
  #5  
Old 07-07-2006, 08:51 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
I guess it would be a tough problem to solve--EverNote and OneNote2007 have the same problem, so it's not unique to UR.

For me, it spoils the copy to UR (also send to EN, send to ON, whatever) because I'm not smart enough to look at a web page and tell if it will be copied properly. What I'd like to do is create a folder type data item in UR, then go to the browser and hit copy to UR button whenever I see anything interesting, confident that it will show up as an item in the folder.

But I can't be sure it copied right, so every time I hit the copy to UR button I have to go to UR and see if it copied properly. I have to expand the folder contents in DE, click on the newly added web page, and check if it got copied OK. If not, I have to delete the contents of the data item, go back to IE and try select all, copy to clipboard, change to UR, paste (or drag and drop.)

Often, that doesn't work either, so I have to delete again. Then what I do is go back to IE and use SnagIt (www.techsmith.com) to capture an image of the web page to the clipboard, then switch to UR and paste it. Since it's an image, the links are dead, but at least I can read it. Then I have to remember to highlight the folder in DE so the next copy to UR will go in the right place.

I find this so tedious that I just use SnagIt to begin with. I snag the web page image, switch to UR, insert a child in the folder, type a name for the child, click in the data item, and paste. But this is not nearly as productive as it would be if it worked the way I'd like.

BTW, I have the same problem with copy to UR from Outlook. Somtimes I get the HTML source rather than what I see when I'm using Outlook.
Reply With Quote
  #6  
Old 07-07-2006, 04:49 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Quote:
Originally posted by Elbert
I guess it would be a tough problem to solve--EverNote and OneNote2007 have the same problem, so it's not unique to UR.
IE7 is still in beta--you could report the problem in hopes that they might fix it.

Quote:
I find this so tedious that I just use SnagIt to begin with. I snag the web page image, switch to UR, insert a child in the folder, type a name for the child, click in the data item, and paste. But this is not nearly as productive as it would be if it worked the way I'd like.
You also lose keywording of the content, use of the page's icon, etc. The page you mentioned was the first I'd ever seen act that way, so I wouldn't expect it to be very common. We do intend to support native paste of image content on the clipboard as a UR image item in the future, which should allow copy/global paste into UR from SnagIt (you'd still have to name the item manually).

Quote:
BTW, I have the same problem with copy to UR from Outlook. Somtimes I get the HTML source rather than what I see when I'm using Outlook.
Can you ZIP and post or send an Outlook item with this problem?
Reply With Quote
  #7  
Old 07-08-2006, 05:29 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
>>Can you ZIP and post or send an Outlook item with this problem?<<

Please see attached.
Attached Files
File Type: zip msg sample to ur.zip (17.7 KB, 644 views)
Reply With Quote
  #8  
Old 07-08-2006, 07:48 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Here's another one that doesn't work:

http://www.clicksewickley.com/newcomers.html
Reply With Quote
  #9  
Old 07-10-2006, 07:45 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Regarding the .msg file, for messages that have both a text and HTML part, UR shows the text part in the mime viewer. You can still view the HTML format (if Outlook is configured to show it) by viewing externally (by clicking 'click here to open message' or Ctrl+J).
Reply With Quote
  #10  
Old 07-11-2006, 04:12 AM
urer urer is online now
Registered User
 
Join Date: 05-24-2006
Posts: 11
Copy to UR doesn't work properly.

http://www.cnsw.org/bbs/redirect.php...oto=nextoldset
Reply With Quote
  #11  
Old 07-13-2006, 10:15 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
The url referenced earlier (http://www.clicksewickley.com/newcomers.html) in this thread, which demonstrated that embedded flash isn't stored with a stored web page has been updated in the latest version of Ultra Recall (2.0c, now available for download).

Embedded flash will be downloaded when the Retrieve script checkbox at Tools | Options | Import (more) tab is checked. In addition a MOTW (mark of the web string) is now added so IE will use Internet zone rights when viewing the locally stored page. However, this doesn't resolve the issue when Ultra Recall later displays the html with embedded flash due to a bug in IE.

You can confirm that this behavior is due to IE by opening the above url in regular Internet Explorer, saving the page as a complete web page, then reopening this locally stored page in IE. The flash image is stored on disk (and an appropriate reference is in the html), but the flash content will not be displayed by IE.

One workaround is to use Open Document in Ultra Recall to open the web page externally in the Firefox browser (which displays the webpage including the flash content properly).

The other reported problem url (http://www.cnsw.org/bbs/redirect.ph...goto=nextoldset) is still being investigated, but a simpler workaround exists, simply copy the entire web page (Ctrl+A then Ctrl+C) in the browser, then paste (or drag and drop) this content into Ultra Recall - the page is stored as expected. We will continue investigating this issue and include a fix for it in a later version of Ultra Recall if a resolution is found.
Reply With Quote
  #12  
Old 07-14-2006, 12:12 AM
urer urer is online now
Registered User
 
Join Date: 05-24-2006
Posts: 11
Another copy to UR doesn't work properly.

http://www.p3china.com/p3bbs/dispbbs...rdID=2&ID=2038
Reply With Quote
  #13  
Old 07-18-2006, 09:06 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
A test build w/ fixes for the last 2 URLs mentioned is available at http://www.kinook.com/Download/UltraRecallProTest.exe
Reply With Quote
  #14  
Old 07-18-2006, 10:48 PM
urer urer is online now
Registered User
 
Join Date: 05-24-2006
Posts: 11
http://www.p3china.com/p3bbs/dispbbs...rdID=2&ID=2038 still doesn't work properly (UltraRecallProTest.exe).
Reply With Quote
  #15  
Old 07-19-2006, 10:18 AM
kevina kevina is online now
Registered User
 
Join Date: 03-26-2003
Posts: 825
For some reason, the server at http://www.p3china.com/p3bbs/dispbbs...rdID=2&ID=2038
sometimes returns content that is not the complete web page (instead it returns an almost empty "refresh in 3 seconds" page).

In our testing, re-syncing the stored page consistently retrieves the expected content. Another option is to select all, then copy and paste into Ultra Recall, as previously mentioned.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:00 AM.


Copyright 1999-2019 Kinook Software, Inc.