Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-13-2006, 01:49 PM
martys martys is online now
Registered User
 
Join Date: 06-09-2006
Posts: 24
InstallShield Pro 7 Question

A few of the steps near the very end of my build are running InstallShield compilers. I have noticed that the InstallShield does not compile properly, even from the IS UI, unless I delete the Media Disk images first (even if I do a refresh build). That's a problem for elsewhere. My problem here is that even when I do delete the images, it still doesn't build correctly from VisBuild, even though it does from IS.
Reply With Quote
  #2  
Old 06-14-2006, 06:37 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
It sounds like an issue with IS when building from the command line (what the InstallShield action ultimately invokes to actually compile a script). You can verify this by checking the 'Log the command-line that is used' checkbox on the Options tab, rebuilding the step, then copying and pasting the command-line from the build output to a Command Prompt and running it from there. If it occurs outside of VBP, you'll need to open a support incident with the vendor of IS. Otherwise, we'll need a reproducible case to investigate further, including:
1) The info from Help | About | Install Info
2) The .bld file used to build
3) A build log file
4) An IS script that fails in this manner
Reply With Quote
  #3  
Old 06-16-2006, 09:22 AM
martys martys is online now
Registered User
 
Join Date: 06-09-2006
Posts: 24
I noticed that if I create a batch file to compile the script from within IS, and run that from VisBuild, it works just fine. So there must just be some differences between the way VisBuild creates the command line to run and the way InstallShield does. It may have something to do with the include files, I think.
Reply With Quote
  #4  
Old 06-16-2006, 12:34 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Hmmm. Can you ZIP and post or send:
1) The info from Help | About | Install Info
2) The .bld file used to build
3) A build log file (with 'Log the command-line' on the Options tab of the InstallShield action checked)
4) The batch file generated by IS to compile the script
Reply With Quote
  #5  
Old 06-16-2006, 02:39 PM
martys martys is online now
Registered User
 
Join Date: 06-09-2006
Posts: 24
Here's a ZIP of the files. I didn't include the actual log, since I've moved over to the BAT files now and don't have a real log. I just set up the IS to run from VisBuild and got the command lines.
Attached Files
File Type: zip bld.zip (7.8 KB, 738 views)
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 02:40 PM.


Copyright 1999-2019 Kinook Software, Inc.