Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-01-2006, 07:12 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Question Creating a stored document template

I'm new to UR pro and trying to follow the instructions in the UR help topic "stored document template" to make a template for a stored Word document.

With Word I created an empty Word .doc file on the desktop. I shift-dragged it to Templates in UR. I renamed the item "Word doc". In item attributes I changed Item Title to "New Word doc", and URL to ".doc".

I right click Journal (I'm using the journal sample data base to experiment) and point to Insert Child. The list of templates does not include Word doc.

How do I get my new template added to the list?

Thanks,
Reply With Quote
  #2  
Old 07-01-2006, 09:34 AM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
For templates the title is updated with the Template Name attribute, not Item Title attribute (which is instead the default title for new items created based on the template).
Reply With Quote
  #3  
Old 07-01-2006, 03:52 PM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Thanks for the reply, kevina. I had changed the name of the item by right clicking its name in data explorer, selecting rename, and keying in "Word doc". "Word doc" appeared in item attributes as Template Name. I also tried keying "Word doc" into the attribute field directly.

But "Word doc" does not show up in the list of templates when I try to insert a child.

Thanks again.
Reply With Quote
  #4  
Old 07-01-2006, 05:56 PM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
Not sure, try a repair (Tools | Compact and Repair) -- ensure the Repair database checkbox is checked.
Reply With Quote
  #5  
Old 07-01-2006, 10:38 PM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Tried it, didn't help. Deleted the template and recreated it, still not in template list. Also created a template of type folder--it's not in the list either.

Templates of type journal entry, year, and month (which I believe are not default types but were created for the journal sample database) do appear in the list. I suspect I'm missing one crucial step.
Reply With Quote
  #6  
Old 07-01-2006, 10:42 PM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
How is your database different than this sample which has an empty Word document template?

(My Journal.urd attached in a zip file)
Attached Files
File Type: zip my journal.zip (117.1 KB, 515 views)
Reply With Quote
  #7  
Old 07-03-2006, 07:07 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Your "New Word doc" template in your "My Journal" worked fine.

Your Item Title atribute had no spaces in the name and had the extension .doc, so I changed mine to be NewDoc.doc, just like yours: still didn't work.

Also your Template Name was "New Word doc", mine was "Word doc". I changed mine to "New Word doc": now it works!! Thinking Word might be a reserved word, I changed the template name to "Nuts doc": still works!!

I also changed the template name of my folder-type template from "Trip" to "Nuts": that template now works. Changed it again to "New Trip": still works.

So "New Word doc" and "Nuts doc" work, but "Word doc" doesn't. "Nuts" and "New Trip" work, "Trip" doesn't. I cycled through Nuts, New Trip, and Trip a couple of times with the same results. I deleted the template Trip and made a new one named Trip. Same results.

Since the .urd you sent works and mine doesn't, I figured the problem is with the .urd not with UR itself. I saved journal.urd as BadJournal.urd, removed UR and reinstalled. I have no problem with templates in the newly installed journal.urd. Problems continue with BadJournal.urd.

So somehow the original journal.urd went flooey, or I accidentally did something to screw it up. Both of these possibilities are a little scary.
Reply With Quote
  #8  
Old 07-03-2006, 08:11 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
Please ZIP and post or send BadJournal.urd to support@kinook.com. Thanks.
Reply With Quote
  #9  
Old 07-03-2006, 10:24 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Duh. I should have thought of that. See attached.
Attached Files
File Type: zip bad journal.zip (127.5 KB, 501 views)
Reply With Quote
  #10  
Old 07-03-2006, 11:41 AM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
The issue here is a minor bug in Ultra Recall - if a template is in the Recycle Bin with the same name as a current template, the current template might not be displayed properly.

The simple workaround is to empty the Recycle Bin or ensure that you remove any templates in the Recycle Bin with the same name as any current templates.

A fix for this bug will be included in a future update of Ultra Recall.
Reply With Quote
  #11  
Old 07-03-2006, 11:51 AM
Elbert Elbert is online now
Registered User
 
Join Date: 07-01-2006
Posts: 25
Thanks!
Reply With Quote
  #12  
Old 07-07-2006, 05:58 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
A test build of v2.0c, which should resolve this issue, is available at http://www.kinook.com/Download/UltraRecallProBeta.exe
Reply With Quote
  #13  
Old 10-24-2006, 09:48 AM
Ortwin Ortwin is online now
Registered User
 
Join Date: 10-24-2006
Location: Germany
Posts: 8
I just experienced the same problem, and was glad to find an explanation here, after I solved it myself ... but I'm using 2.0d - so it still exists.
Reply With Quote
  #14  
Old 10-25-2006, 08:13 PM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
If you can either send your database, or create a small .urd file that reproduces the problem with Ultra Recall 2.0d, we will take a look at it - we can't reproduce the problem. Please send the database to support@kinook.com.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:21 AM.


Copyright 1999-2019 Kinook Software, Inc.