Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-04-2009, 07:30 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
Macro initialisation

I initial a macro to false by using the "set macro" step. In the "macro" field I either put -1 or [true]. This macro get sets to 0 or [false] by using the "set macro" step too. I am then using this same macro in "vbscript" step. I am using "set macro name = vbld_AllMacros()("macro name")" in the script to retrieve the value of this macro. I am using the msgbox routine to display the value. The value displayed is 0 but I would prefer to see "false". My real concern is that when I have got the following line in the script "if macro = false then .... endif", I would expect that the condition is true and then execute the if statement but it does NOT. Please can you advise?
Reply With Quote
  #2  
Old 02-04-2009, 10:11 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,758
See attached sample.
Attached Files
File Type: bld macro.bld (937 Bytes, 613 views)
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:52 AM.


Copyright 1999-2019 Kinook Software, Inc.