Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-10-2005, 05:17 PM
epu epu is online now
Registered User
 
Join Date: 10-29-2003
Location: San Francisco, CA
Posts: 29
vc6 dsw trying to find deps at wrong path?

Hey,

Since my last post was user error, maybe you can help me figure out what I'm doing wrong. Pointers to manual appreciated.

I have a .dsw that I can open in my VC6 ide and it finds the children ok, but when I set my VC6 action to build this .dsw, it tries to find the deps one directory up.

So, when I try to build C:\baz\foo\bar.dsw that depends on C:\baz\frob\frob.dsp, it prints

Processing 'C:\frob\frob.dsp'
Failed to open 'C:\frob\frob.dsp': No such file or directory

instead of the directory I expect, 'C:\baz\frob\frob.dsp'.

How does visual build process dependancies in a vc6 file and determine their paths? Is there a setting I need to toggle in my DSW, or a macro I can set?

Running msdev manually from the directory of C:\baz\foo\, like 'C:\Program Files\Microsoft Visual Studio\Common\MSDev98\bin\msdev.exe frob.dsw /MAKE all /rebuild' works ok.

Last edited by epu; 05-10-2005 at 05:29 PM.
Reply With Quote
  #2  
Old 05-11-2005, 08:59 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,720
The Make VC6 action combines the .dsw file path with each constituent .dsp file's path (if that path is relative). Please zip and post (or send to support@kinook.com) the .bld and .dsw+.dsp files where this is not working properly. Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 01:12 AM.


Copyright 1999-2019 Kinook Software, Inc.