Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-06-2008, 11:01 AM
DuncanL DuncanL is offline
Registered User
 
Join Date: 07-26-2007
Posts: 29
VS 2005 step "complete" with error

During a build today I noticed one of our projects build with an error. It is a Visual Studio 2005 VB .Net project and the problem was that a reference could not be resolved. The error was of the form:
Quote:
Failed to create the wrapper assembly for type library "Control". Did not find a registered ActiveX control in 'Control'.
0 Warning(s)
1 Error(s)
However, VisualBuild Pro merrily treated the build as successfully completed and carried on. I just happened to see the error and stop the build.

Any ideas why that might be and what we could do to make it return an error? I assume it's a Visual Studio issue rather than VBP?
Reply With Quote
  #2  
Old 03-06-2008, 11:12 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,743
The VBP Make VS.NET/2005 actions key success/failure off of the exit code of devenv/msbuild, so it appears to be returning 0 (success) here, which sounds like a (VS) bug if any project(s) failed to build.

You could try checking 'Parse build output for failed projects' on the Project/Solution, which will parse the output and fail if ", 0 failed" is not found (but this only works with devenv output and not msbuild).

Alternatively, you could parse the output in the step's vbld_StepDone script event and fail the step if "<non-0> Error(s)" was found.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:12 PM.


Copyright 1999-2019 Kinook Software, Inc.