Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-20-2004, 02:44 PM
jnapier jnapier is online now
Registered User
 
Join Date: 07-29-2003
Posts: 32
VS.Net Wb Projects not getting incremented

I just downloaded version 5.2 and I am still getting a problem when trying to increment the version of a web project.

I am using vs.net 2003, visual build 5.2 on windows 200 advanced server.

When the make vs.net action goes to increment the versions it locates the wrong web project. The following is the output from the step when it tries to increment the version.

Post-processing...
D:\Solutions\WebSolutions\RNCSolutions\ServiceDesk Solution\WebSite\WebSite.csproj...(no changes)
D:\Solutions\WebSolutions\NGSolutions\IbisProjectS olution\DataAccess\DataAccess.csproj...incrementin g version...
D:\Solutions\WebSolutions\NGSolutions\IbisProjectS olution\BusinessObjects\BusinessObjects.csproj...i ncrementing version...
D:\Solutions\WebSolutions\NGSolutions\IbisProjectS olution\WebControls\WebControls.csproj...increment ing version...
D:\Solutions\WebSolutions\NGSolutions\IbisProjectS olution\NunitTests\NunitTests.csproj...incrementin g version...


Notice how the first project it tries to update is in the ServiceDeskSolution. This is wrong. Notice how the other projects are in the IbisProjectSolution. This is correct.

Why is it locating a different web project than what it built.

Let me know if you need any more infromation.
Reply With Quote
  #2  
Old 01-21-2004, 02:12 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,742
We weren't aware that you were experiencing a problem. There weren't any changes in the 5.2 release regarding how the VS.NET action locates web projects. The action tries several methods to convert a web project to its local filename (so that it can update versions, properties, etc.); apparently one of these is resulting in a false positive on the wrong filename. Please send to support@kinook.com:

1) The .bld file, .sln file, and constituent project files (no source code files)
2) The output of a "dir C:\Solutions /s > dir.txt" from a command prompt
3) The version of IIS you are running
4) Details about your web site configurations. For IIS 4.0/5.0, install the MS MetaBase Editor (download from http://support.microsoft.com/default...NoWebContent=1) and export LM/W3SVC; for IIS 6.0, they're found in C:\Windows\System32\InetSrv\MetaBase.xml.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:25 AM.


Copyright 1999-2019 Kinook Software, Inc.