Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
  #1  
Old 10-12-2005, 04:20 PM
epu epu is online now
Registered User
 
Join Date: 10-29-2003
Location: San Francisco, CA
Posts: 29
incredibuild vc6 lib dependancies problem

Hey team,

I have a project that builds and compiles ok using vc6 and checking the 'project workspace->support library dependancies when building multiproject workspaces' checkbox.

When I set 'options->msdev overide...' to incredibuild console, the libraries are not built first so link fails.

I can work around this, but is incredibuild compatible with this option? It'd be nice if it 'just worked'.

Thanks for VBP,

-e
Reply With Quote
  #2  
Old 10-12-2005, 04:22 PM
epu epu is online now
Registered User
 
Join Date: 10-29-2003
Location: San Francisco, CA
Posts: 29
versions

sorry.

Incredibuild 2.41

Visual Build Professional 5.7
Registered to: **********
Windows Version: 5.1.2600.2.0
Install path: C:\Program Files\VisBuildPro
cmax20u.dll version 2.1.0.21
SftTree_IX86_U_45.dll version 4.5a
SftTree_IX86_U_50.dll version 5.01
unins000.exe version 51.15.0.0
VisBuildBld.dll version 5.7.0.0
VisBuildCmd.exe version 5.7.0.0
VisBuildCore.dll version 5.7.0.0
VisBuildDotNET.dll version 5.7.0.0
VisBuildExt.dll version 5.7.0.0
VisBuildLog.dll version 5.7.0.0
VisBuildMisc.dll version 5.7.0.0
VisBuildMS.dll version 5.7.0.0
VisBuildNet.dll version 5.7.0.0
VisBuildPro.exe version 5.7.0.0
VisBuildSvr.dll version 5.7.0.0
Reply With Quote
  #3  
Old 10-12-2005, 04:34 PM
epu epu is online now
Registered User
 
Join Date: 10-29-2003
Location: San Francisco, CA
Posts: 29
6.0 also fails to link

This is also does not work with 10/12/2005 download release of 6.0.
Reply With Quote
  #4  
Old 10-12-2005, 06:20 PM
epu epu is online now
Registered User
 
Join Date: 10-29-2003
Location: San Francisco, CA
Posts: 29
Lightbulb resolved

I fixed this by trying it on the command line and comparing my results. I unchecked a bunch of options in the incredibuild version and also point it to the dsw instead of the dsp.

<code>
<step action='Make VC6' type='1'>
<Attr type='11'>-1</Attr>
<Config>Win32 Release</Config>
<FileVer type='11'>-1</FileVer>
<Filename>%PWD%\Project.dsp</Filename>
<FixLibDep type='11'>-1</FixLibDep>
<Force type='11'>-1</Force>
<ShowCmd type='11'>-1</ShowCmd>
<condcompareto>Error</condcompareto>
<condcomparison type='3'>2</condcomparison>
<condexpr>%INCREDIBUILD%</condexpr>
<indent type='3'>2</indent>
<name>Build Release</name>
</step>
<step action='Make VC6' type='1'>
<Attr type='11'>0</Attr>
<Config>Win32 Release</Config>
<FileVer type='11'>-1</FileVer>
<Filename>%PWD%\Project.dsw</Filename>
<FixLibDep type='11'>0</FixLibDep>
<Location>%INCREDIBUILD%</Location>
<Options>%INCREDIBUILD_OPTIONS% /REBUILD</Options>
<ShowCmd type='11'>-1</ShowCmd>
<condcompareto>Error</condcompareto>
<condcomparison type='3'>5</condcomparison>
<condexpr>%INCREDIBUILD%</condexpr>
<indent type='3'>2</indent>
<name>IncrediBuild Release</name>
</step>
</code>
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:07 AM.


Copyright 1999-2019 Kinook Software, Inc.