Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-10-2008, 04:44 PM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
Unhappy Internal versus External Viewing of Web Pages

I've got a database with linked web pages in it that naturally open in the internal browser.

I've also got a csv file with a whole bunch of web pages (Item Titles and URLs) that I'd like to import and to open in the internal browser. No matter what I do after importing them, seemingly successfully, I can't get them to open internally. When I click on one of the items I've imported, there's the link "Click here to open linked document" displayed in the item detail. Now, I've been careful to import to document-type items and I've used the two item attributes "Item Title" and "URL" only.

Can you tell me what the heck I'm doing wrong here?
Reply With Quote
  #2  
Old 06-10-2008, 05:11 PM
ashwken ashwken is offline
Registered User
 
Join Date: 10-16-2005
Location: Blairsville, GA USA
Posts: 431
Launch the Item Attribute pane (Ctrl-4) for the Document Items created from the csv import and look at the value for DocType (default seems to be 13), try changing this to "1" (w/o the quotes).

This DocType value is different depending on the type of document stored. I recall seeing a list of these values but can't put my finger on it. If the above change works you can apply the Attribute change across mutliple selections, or (possibly) set the value during the import stage.

Maybe Kinook has a better answer (more depth).

EDIT: Obvious question, look at Tools | Options | Broswer - file extensions to display in internal browser - should look something like this:

.html;.htm;.mht;.ico;.doc;.xls;.ppt;.pdf;.zip;*fol der

Last edited by ashwken; 06-10-2008 at 05:20 PM.
Reply With Quote
  #3  
Old 06-11-2008, 09:16 AM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
Quote:
Originally posted by ashwken
Launch the Item Attribute pane (Ctrl-4) for the Document Items created from the csv import and look at the value for DocType (default seems to be 13), try changing this to "1" (w/o the quotes).

This DocType value is different depending on the type of document stored. I recall seeing a list of these values but can't put my finger on it. If the above change works you can apply the Attribute change across mutliple selections, or (possibly) set the value during the import stage.

Maybe Kinook has a better answer (more depth).

EDIT: Obvious question, look at Tools | Options | Broswer - file extensions to display in internal browser - should look something like this:

.html;.htm;.mht;.ico;.doc;.xls;.ppt;.pdf;.zip;*fol der
WOW! That did it. Nice secret. Next time I create a bunch of links from an external file, I'll add the DocType column to each record with a value of 1.

Your afterthought about internal browser extensions was a good one, but here I've got URLs without extensions. It's a completely dynamic site where every page is produced by a call to a cgi monster followed by parameters.

THANK YOU. You get the weekly award for obscure info. I am so glad I asked.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:30 PM.


Copyright 1999-2019 Kinook Software, Inc.