Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-03-2011, 12:38 PM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
How To Edit Plain Text Import?

Hi all,
I'm importing .txt files and I can see that UR is displaying them as plain text i.e. line numbers, syntax highlight. However, I can not edit the contents of the newly imported item. The help file is not clear as it refers to 'text document editor component' ...

----------------------------------------
For plain text Info Items (ie. an Info Item for a .txt file), Ultra Recall will display (and allow editing) in the Text Document Editor component of the Item Details Pane.
----------------------------------------

What am I missing?

Thank you.
Reply With Quote
  #2  
Old 02-03-2011, 12:45 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
If you are storing in UR, add .txt to Tools | Options | Documents | File extensions to open stored documents writeable (you may need to restart UR). If you are linking in UR, check Tools | Options | Documents | Allow internal editing of linked documents (and make sure the file is not read-only on disk).
Reply With Quote
  #3  
Old 02-03-2011, 01:08 PM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
Splendid.
May it would be nice if you update the help doc to reflect this. Thank you.
Reply With Quote
  #4  
Old 02-03-2011, 01:47 PM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
May it is even a better idea to have UR list plain text item as one of the defaults templates. This exposes this new and nice functionality much easier.

Thank you.
Reply With Quote
  #5  
Old 01-19-2012, 08:30 AM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
Moving content to a new windows 7 machine, all plain text items are now read-only

Hi all ...
Why all my plain text items are now read-only. Also, trying to import a new .txt item is not working as it is not displaying the plain text editor features e.g. lines, code syntax, etc.
I have verified ...
1) txt file I'm importing is NOT RO.
2) Options set as recommended (see images).

Again, what is missing here?
Attached Images
     
Reply With Quote
  #6  
Old 01-19-2012, 08:35 AM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
... and I did reboot UR too.
Reply With Quote
  #7  
Old 01-19-2012, 08:41 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
What do you mean "are now read-only"? The URTextTemplate.txt item appears to be a linked document and not configured to edit within UR. Is .txt in Tools | Options | Editor | File extensions to display in text editor?
http://www.kinook.com/Forum/showthread.php?t=3038
Reply With Quote
  #8  
Old 01-19-2012, 02:07 PM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
Yes it is set.
I tried importing and storing a .txt file in UR, but neither one is displaying text editor pane.

- You can see from the image that clicking on the info item, shows a blank editor. I will get you a screen replay on how to reproduce the issue.

I wish Kinook makes the txt template a default one just like others without having to get through this messy process.

Thank you.
Attached Images
   
Reply With Quote
  #9  
Old 01-19-2012, 03:24 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
It's fairly automatic in my tests. See screen recording on a clean Win 7 x64 + UR Pro 4.2b install: http://www.kinook.com/Download/Temp/TextDoc.zip
Reply With Quote
  #10  
Old 01-20-2012, 11:02 AM
cnewtonne cnewtonne is online now
Registered User
 
Join Date: 07-27-2006
Posts: 436
won't open ...

Extracting to "C:\Users\...\AppData\Local\Temp\"7

Use Path: no Overlay Files: yes
skipping: TextDoc.avi this file is not in the standard Zip 2.0 format.
Please see www.winzip.com/zip2.htm for more information.
Version needed value for this file is 63.
Compression method value is 14.
error: no files were found - nothing to do

I'll see if I have time today to research it.
Reply With Quote
  #11  
Old 01-20-2012, 05:50 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
You need to use a recent version of WinZip or 7-Zip, since it is compressed with a newer compression method (that shrinks the file a lot more than older methods).
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:59 PM.


Copyright 1999-2019 Kinook Software, Inc.