Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-06-2007, 08:16 AM
dasymington dasymington is online now
Registered User
 
Join Date: 06-15-2005
Posts: 287
Thunderbird plug-in not working

When I try to import an email message using this it sort of half works - once. It imports the message, but the item title is email1.eml, and I can't get UR to display the subject as the title. Then whenever I try to import another message to the same folder in UR it says it's done it, but it hasn't. If I try to import another message to a different UR folder, it imports the same message as the first time.

Does anyone know if this ever worked and has perhaps been broken with the latest UR build?
Reply With Quote
  #2  
Old 10-06-2007, 08:52 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,741
Make sure 'Tools | Options | Import (More) | Use document title for item title if available' is checked.
Reply With Quote
  #3  
Old 10-07-2007, 04:44 AM
dasymington dasymington is online now
Registered User
 
Join Date: 06-15-2005
Posts: 287
Quote:
Originally posted by kinook
Make sure 'Tools | Options | Import (More) | Use document title for item title if available' is checked.
Yes, that was already checked, and I had tried it with it unchecked. In any case, surely that wouldn't explain why UR will only ever import the first email and continue to import that same email each time I try to import another one, until I delete the first one?

I've tried:

- a different UR database;
- rebooting my PC;
- uninstalling and re-installing the UR Thunderbird add-on 1.1.
Reply With Quote
  #4  
Old 10-07-2007, 08:17 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,741
The extension creates files in %TEMP%\UltraRecall named email1.eml, email2.eml, etc., for each selected item, then imports them into UR (move), and UR deletes the temp files from disk afterwards (but the extension will also overwrite these file(s) on the next run if they still exist).

In our tests w/ UR 3.2.5 and Thunderbird 2.0.6 and the previously mentioned option checked, this works as expected, with each UR item having the content and title of the selected TB message when importing individual messages via the UR T-Bird plugin into the same or different locations.

This should unnecessary, but does unchecking 'Tools | Options | Import (More) | Create logically linked items for duplicate URLs' help? Otherwise, please send the info requested at http://www.kinook.com/Forum/showthre...threadid=3038. Thanks.
Reply With Quote
  #5  
Old 10-07-2007, 08:58 AM
dasymington dasymington is online now
Registered User
 
Join Date: 06-15-2005
Posts: 287
Quote:
Originally posted by kinook
This should unnecessary, but does unchecking 'Tools | Options | Import (More) | Create logically linked items for duplicate URLs' help? Otherwise, please send the info requested at http://www.kinook.com/Forum/showthre...threadid=3038. Thanks.
Unchecking that option allows UR to import more than one message, but they all have the item title email1.eml (which isn't satisfactory), even with the Use page title for item title if available option checked.

With Create logically linked items for duplicate URLs checked, I notice that the file email1.eml does in fact contain the new email I try to import, but it doesn't get imported. If I go to the temp folder and manually import the file email1.eml, it imports the correct content, but the item title is still email1.eml. If I open that file in Thunderbird, it shows the correct subject. UR shows the URL of the message it imported using the plug-in as C:\DOCUME~1\Dave\LOCALS~1\Temp\ultrarecall\email1. eml, but that of the message I imported manually as C:\Documents and Settings\Dave\Local Settings\Temp\UltraRecall\email1.eml. Don't know if that helps.

UR also imports, using the plug-in, if I uncheck Select location when importing from other apps, but again itf calls all the imported items email1.eml.

I'm using Thunderbird 2.0.0.6.

I'll send you the information you've requested for debugging, but I'm not sure a sample urd will help, as it happens with them all.
Reply With Quote
  #6  
Old 10-07-2007, 09:22 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,741
If the 'Select import location...' option is checked, you will need to uncheck the 'Create logically linked...' option (the TB extension commands UR to move the files in, which stores the URL without its path and prevents it from identifying as a duplicate, but the Select dialog only allows copy/link). We'll also add this to our list to fix.

I'm not sure why the subject is not being used for the item title with the 'Use document title...' option checked (I exported the .eml files from your sample db and they imported properly with title). We'll need to send you a debug build to investigate further.
Reply With Quote
  #7  
Old 10-09-2007, 05:16 PM
dasymington dasymington is online now
Registered User
 
Join Date: 06-15-2005
Posts: 287
Thanks to Kinook for their help in resolving this: I was checking the option under Web Import instead of under File Import. Silly me!
Reply With Quote
  #8  
Old 10-09-2007, 06:07 PM
janrif janrif is offline
Registered User
 
Join Date: 07-08-2005
Location: Ridgefield CT USA
Posts: 852
Just FYI.

I don't normally use GMail but tried it today & it seemed to work as expected, i.e. importing from %temp% file & inserting subject as title. w2k-sp4 machine.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:50 AM.


Copyright 1999-2019 Kinook Software, Inc.