Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
  #1  
Old 02-04-2005, 08:30 AM
jaylab jaylab is online now
Registered User
 
Join Date: 06-27-2004
Location: Boston
Posts: 13
Question Building .Net Web Projects on Windows 2003

I have a Visual Build project running on Windows 2000 that builds .Net web projects just fine. I am using the csproj files and not the solution, so I go into the app mappings in IIS and remove csproj. Everything works great. I applied these settings based on other posts I read.

I am now moving my build to run on Windows 2003. The same Visual Build project (working on Windows 2000) gets an error when I try to build my .Net web projects. I have applied the exact same settings as on Windows 2000. The error I am recieving is:

Step default property 'Filename' = 'http://localhost/introspect/searchui/searchui.csproj'
The remote server returned an error: (404) Not Found.

If I try to build from the sln I get the same error:

Step default property 'Filename' = 'C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.sln'
Error loading info for project file 'http://localhost/introspect/SearchUI/SearchUI.csproj': The remote server returned an error: (404) Not Found.

If I specify the full path I get and invalid project error:

Step default property 'Filename' = 'C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj'
Pre-processing...

Rebuilding configuration 'Release'...
Command: "c:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE\devenv.com" "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj" /rebuild Release /project "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj"

Microsoft (R) Development Environment Version 7.10.3077.
Copyright (C) Microsoft Corp 1984-2001. All rights reserved.

Invalid project

I can get the project to compile using the following syntax from the cmd prompt:

devenv.com "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj" /build Release

Is there anything special I need to do on Windows 2003? Can you see where I am going wrong? Any reccomendations to resolve this would be great.
Reply With Quote
  #2  
Old 02-05-2005, 07:58 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
You shouldn't need to do anything special. Check this thread and see if it helps:
http://www.kinook.com/Forum/showthread.php?threadid=843
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 11:17 PM.


Copyright 1999-2019 Kinook Software, Inc.