Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-27-2006, 10:50 AM
HippyCraig HippyCraig is online now
Registered User
 
Join Date: 07-27-2006
Location: Philly
Posts: 211
PSInfo

I am trying to run "PSInfo -s" command on a remove server to get an list of all application on the server. I keep getting a return code of 1. I do get the list I need from this command. I just added that an exit code of 1 is successful.

Is this correct or does this mean that its erroring out?

Also is there an event that I can trap for that will give me the current output of this action in a variable so that I can do a string lookup. Or do I just have to read in the log file that is created?

The perpose of this is I want to check to see if the software exists before running an uninstall command. If I just run an uninstall command on a remote server the build just hangs.

Thanks,
Craig
Reply With Quote
  #2  
Old 07-27-2006, 11:05 AM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
The 1 exit code is being returned by psInfo, so whether this is actualy an error or not depends on this application...

THe RUNPROGRAM_EXITCODE temporary macro can be used to see the ExitCode of the last Run Program step, the LASTSTEP_OUTPUT temporary macro contains the output.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 04:44 AM.


Copyright 1999-2019 Kinook Software, Inc.