Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-25-2005, 11:58 AM
ASolovey ASolovey is online now
Registered User
 
Join Date: 05-25-2005
Posts: 13
Unhappy VS .NET 2003 solution: Building non-existing configuration with empty name

I have VBP 5.6 installed. In the build script I have a step that builds single configuration (Release) of VS .NET 2003 solution.
It works fine in most cases. But sometimes, after solution is changed (projects added, or something - I haven't figured any regularity), VBP begins building it wrongly. After successfull building of Release configuration it immediately attempts to build one more configuration with empty name (which of course does not exist).

It displays the following:
------------------------------------------
Building configuration ''...
Command: "C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE\devenv.com" D:\BuildRoot\PROGRAM\MyProject\REL_1.0.1\BUILD\WOR K\SOURCE\MyProject.sln /build
------------------------------------------
VS7 of course says that the command line is invalid, configuration name is missing.
------------------------------------------
Invalid solution configuration

Usage:
devenv [solutionfile | projectfile | anyfile.ext] [switches]
------------------------------------------

I have upgraded VBP up to 5.7. It didn't help.
Nothing helps in this situation except re-creating the solution from scratch.
Is it a well known issue?
Can you help us to resolve it?
How should we approach it?

Thanks in advance.

Last edited by ASolovey; 05-25-2005 at 12:02 PM.
Reply With Quote
  #2  
Old 05-25-2005, 12:04 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
It hasn't been reported before now. Please zip and post (or send to support@kinook.com) the .sln file + .bld file that results in this problem. Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 12:26 PM.


Copyright 1999-2019 Kinook Software, Inc.