Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-15-2006, 06:16 PM
TimSchroeder TimSchroeder is online now
Registered User
 
Join Date: 10-13-2006
Location: Bergheim, Austria
Posts: 2
Question OL-related bugs when UR or OL are not already running?

I just bought UR Professional some days ago (Version 2.0d) and it generally works really fine. However, I experienced two kinds of strange behaviour:

1. I've imported messages from OL (2003), some of them just linked and others stored. When I view this messages inside UR while OL is not already running and I click on the link "Click here to open message" in UR, then OL will try to start but hangs everytime before something is displayed on the screen. I then have to terminate the OL process manually in the task manager. Clicking on the links works if OL is already running.

2. When I use the OL toolbar buttons of UR to import (link or store) messages and UR is not already running, UR will start up, import the message successfully, but everytime just after the info "completing operation, please wait" is shown an error message will show up in UR: "Error loading item(s): Access violation. Exception 0xC0000005 occured in module C:\Programme\UltraRecall\UltraRecall.exe at address ...". This won't happen if UR is already running.

I'm really not sure if this behaviour is due to my computer's configuration or possibly due to something inside UR?

Thanks,

Tim
Reply With Quote
  #2  
Old 10-16-2006, 04:32 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,758
1. UR is using the ShellExecute API [1] to open the stored Outlook message (via its outlook: url if linked or via the filename of a temporary copy if stored). I'm not sure what would cause Outlook to hang when launched in that way (very similar to double-clicking a .msg file in Explorer or typing its outlook: url into the Run dialog), and I wasn't able to reproduce the problem here with Windows XP SP2 and Outlook 2003 SP2.

2. I wasn't able to reproduce this either. Please send or post the info from Help | About | Install Info.

[1] http://tinyurl.com/hsgz
Reply With Quote
  #3  
Old 10-22-2006, 10:49 AM
TimSchroeder TimSchroeder is online now
Registered User
 
Join Date: 10-13-2006
Location: Bergheim, Austria
Posts: 2
Tracked down one issue

I tracked down the first of the two issues I described in my earlier post: Outlook will crash on startup only if the mail message which has been imported as a link in UR is not stored in the default .pst-file of Outlook but in a separate .pst-file (which is open in Outlook, of course). In other words clicking on the link in UR will work fine if the message is in the default .pst-file, Outlook already running or not.
Reply With Quote
  #4  
Old 10-23-2006, 11:21 PM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
This is reproduceable, but is apparently an Outlook issue. As stated before, what Ultra Recall is doing to launch the item is identical to entering the url to the Outlook object in the address bar of Internet Explorer (which also causes the same error).

The workaround is to ensure that Outlook is running before launching a linked Outlook object from external applications (including Ultra Recall).
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:33 PM.


Copyright 1999-2019 Kinook Software, Inc.