Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-19-2022, 01:01 AM
GoGoJoe GoGoJoe is online now
Registered User
 
Join Date: 05-12-2020
Posts: 7
Quick Search - Titles Only - Failing?

I am getting some results that I do not understand when using Quick Search.
Perhaps you can help discuss or otherwise help me better understand what is happening.

Typically, I am doing a Quick Search with the “Search titles only” as the only active check box.
In Options – I have – Match anywhere in word by default. I have not done anything in the Options, that I know would mess up the Quick Search.
I am a new user of Ultra Recall, and I created my UR database by importing starting from a root folder, with many subfolders and files which were created by my previous PIM software.

Here is a series of Quick Searches I attempted as an Example.
When I say Failure – I mean that the Quick Search did not find what I am looking for.
When I say Success – I mean that the Quick Search did find the item.
My UR has a jpg scanned in image of my Drivers License which I wish to find.
The Item Title is: Robert_DriversLicenseVirginiaExpires20280126.jpg

Search – Robert --- 131 matching items found. Success
Search – Virginia – 26 matching items found. Success
Search – Robert Drivers -- 2 matching items found. Failure. Hoped for item not found.
Search -- Robert AND Drivers – 0 matching items. Failure. Hoped for item not found.
Search – Robert License – 2 matching items found. Failure. Hoped for item not found.
Search -- Robert Expires – 3 matching items found. Failure. Hoped for item not found.

I suspect that this is failing because I did not use Spaces to make separate words in the title of this jpg file. Rather my title is one long String.
The Quick Search seems to be failing for me when I search using multiple terms.

Discuss or Help Please.
Reply With Quote
  #2  
Old 07-19-2022, 10:29 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,908
The search will match on the phrase that you enter. Since the title does not contain "...Robert<space>Drivers..." or "...Robert<space>License..." or "...Robert<space> Expires...", it does not match. The AND search is searching for those two words (not in the middle of a word, but distinct words) in the title/text.

To search within a word like that, you could use an Advanced search like

(Item) matches wildcard Robert
and (Item) matches wildcard Drivers

or if Tools | Options | Search | Match anywhere in word by default is unchecked

(Item) matches wildcard *Robert*
and (Item) matches wildcard *Drivers*
Reply With Quote
  #3  
Old 07-19-2022, 08:30 PM
GoGoJoe GoGoJoe is online now
Registered User
 
Join Date: 05-12-2020
Posts: 7
Thanks. The Advanced Search is working for me.
Reply With Quote
Reply

Tags
failing , search , titles , unexpected

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:41 PM.


Copyright © 1999-2022 Kinook Software, Inc.