Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-30-2006, 03:55 PM
Albert Albert is online now
Registered User
 
Join Date: 08-18-2006
Posts: 9
Add files to VSS does not work recursively

When I use the Visual Source Safe step and specify the Add action for some reason only the files in the directory specified get added. Files that are in subfolders do not.

I checked the Perform action recursively on all subdirectories check box and specified * or *.* as the files to process.

Here is the command line form the trace output:

8/30/2006 4:52:15 PM: Building project step 'Add Executables'...
"C:\Program Files\Microsoft Visual Studio\VSS\win32\ss.exe" Add * -R -NL -I-N -Y"Al Raiani",albert -W- -C-

according to visual source safe help the following command line will act recursively. It is slightly different from the above command. Is there something I can do to make this happen?

ss Add .-R *

Thank You!
Reply With Quote
  #2  
Old 08-30-2006, 04:18 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,744
Uncheck the Recursive flag and enter

.-R
*

in the 'Projects and/or files to process' field. Although the docs may be incorrect, as it didn't work in my tests. The add command does work recursively if you specify a folder name (without wildcards), which may be another option (see the SourceSafe.bld sample).
Reply With Quote
  #3  
Old 08-31-2006, 09:55 AM
Albert Albert is online now
Registered User
 
Join Date: 08-18-2006
Posts: 9
You are correct! When you specify the folder then it work recursively however you must specify the folder in the files to process section not in the path for local files section. Only then can I get it to act recursively.

PS: I also tried setting the command string to .-R * and it failed. There still doesn't seem to be an easy way to get just the content and the subfolders without also creating the root folder.

For example:
1. Set CD To $/History/version 1.0.0.0/Executables
2. Specify VSS Action Add and files to process as C:\vbp\build

The result is $/History/version 1.0.0.0/Executables/build instead of just puting the content of the build folder and it's subdirectories into the Executables VSS project folder.

Whew! I guess I can live with it this way but if anyone has any suggestions I would like to hear them.

Thanks!
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 04:38 AM.


Copyright 1999-2019 Kinook Software, Inc.