Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Frequently Asked Questions > Troubleshooting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-25-2010, 11:38 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,654
How to resolve problems with registration not sticking

Some users have reported situations where the Visual Build registration info is lost, and it reverts to operating in evaluation mode (sometimes only when called from a scheduled task). To work around this, use one of the alternative registrations methods:

1) In the Visual Build System folder (typically C:\Program Files\VisBuildPro10\System), create a text file named VisBuildSvr.ini with contents like this:
Code:
[License]
PortableKey=My Company (n-computer license),123456-654321-...-123456
Note: On Windows Vista and later, the editor must be run elevated ("As administrator") in order to create or modify files in a Program Files subfolder. Another option is to create the file in a different folder (for instance, My Documents) and move it into the above folder using Windows Explorer (Windows will prompt for elevation in order to move the file).

Note: After registering with this method, registering again via the About | Register dialog or method #2 will report an invalid key.

or

2) In the project or global vbld_BuildStarting script event, add VBScript code like this:
Code:
Builder.RegisterKey "My Company (n-computer license)", "123456-654321-...-123456"
Note: Replace the license name, count and registration key above with the information from your license info email.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 11:13 AM.


Copyright 1999-2019 Kinook Software, Inc.