Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-28-2011, 09:49 AM
jkurtis jkurtis is online now
Registered User
 
Join Date: 01-28-2011
Posts: 2
ADO Loop error

I'm trying to call a SQL Stored proc from an ADO action, loop over the resulting record set and do something with it and am having some problems.

My ADO call works fine.
My next step is a loop over the %ADO_RS%. This works fine.
The problem is inside of the loop. At this point I'm trying to log the message and am receiving the following error:

Error expanding macros or script in property Message: <Error in System (VBScript) script code at Line 21, Column 2 (Object required: 'vbld_TempMacro(...)')>


I'm attaching my build script for examination. if anyone has any idea whats going on I'd appreciate the help.

Thanks
Attached Files
File Type: bld sql_ado.bld (1.0 KB, 308 views)
Reply With Quote
  #2  
Old 01-28-2011, 10:08 AM
jkurtis jkurtis is online now
Registered User
 
Join Date: 01-28-2011
Posts: 2
Odd -- I think I solved this problem. I was selecting everything and choosing "Rebuild Selected". From the menu bar, if i select "Build -> Rebuild" I don't get the error and my loop works correctly.

No idea what the difference is, but its working now.
Reply With Quote
  #3  
Old 01-28-2011, 10:14 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
http://www.kinook.com/Forum/showthread.php?threadid=927
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:01 AM.


Copyright 1999-2019 Kinook Software, Inc.