Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-22-2009, 06:43 AM
Omi Omi is online now
Registered User
 
Join Date: 02-06-2007
Location: Munich
Posts: 11
VisBuildPro.macros cleared during BuildProcess

Hi all, hi Kinook,

We've got a strange problem with the VisBuildPro.macros (XML Document).

The Macro File gets cleared during our Build Processes ..
not repeatable, or traceable.. nothing gives us a indication, why this happens..

We've got about 10 Build Machines.. and in our automated nightly Build process, sporadically it clears the VisBuildPro.macros File.

This happens so far two times.. with the effect, a clear macro file, is a broken build!

Both times, it happens on different Build Machines, in different time, in differnet *.bld ..
First time immediatly in the beginning (VBP intialize the macros with the start up right)
Second time during the build process, in the execution of the third .bld ...

We shortly developed a tool, which checks the file, to get further information when exactly it is cleared .. one again the file was not deleted , simply 0 KB ...

Any helpful suggestions .. or experiences !?

with best regards...
Omi
Reply With Quote
  #2  
Old 04-22-2009, 06:55 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
I'm pretty sure that VBP itself would not create an empty .macros file. Could some security software or other background process be interfering with VBP writing to the file? Please ZIP and send to support@kinook.com:
1) The info from Help | About | Install Info
2) A screen shot of System properties (Windows+Break)
3) The .bld file(s)
4) A build log file

Thanks.
Reply With Quote
  #3  
Old 04-22-2009, 07:20 AM
Omi Omi is online now
Registered User
 
Join Date: 02-06-2007
Location: Munich
Posts: 11
So it happens! Unfortunately so far thats not visible for us .. thats why we developed a tool which analyze the file ..

1)
Visual Build Professional 7.1
Evaluation Version: 30 days remaining
Windows Version: 5.2.3790.2.0
Install path: C:\Program Files\VisBuildPro7
HideConsole.exe version 1.0.0.0
SftPrintPreview_IX86_U_20.dll version 2.00
VisBuildCmd.exe version 7.1.0.1
VisBuildPro.exe version 7.1.0.2
VisBuildAct.dll version 7.1.0.5
VisBuildCore.dll version 7.1.0.1
VisBuildDotNET.dll version 7.1.0.1
VisBuildExt.dll version 7.1.0.1
VisBuildMisc.dll version 7.1.0.2
VisBuildMS.dll version 7.1.0.3
VisBuildMS2.dll version 7.1.0.1
VisBuildNet.dll version 7.1.0.1
VisBuildSvr.dll version 7.1.0.6
VisBuildSvr.Interop.dll version 1.0.0.0
VisBuildVCS.dll version 7.1.0.1

2) Attachment

3) Sry we build medical Software with about 11 mio lines of code..
i cant deliver u any from our huge bld's. We are a leading software company, from automated: nightly Build -> developer Builds -> Checkin Policies, Code Analyses, branches.. Code metrics etc etc ..

4) We are POWER USER.. we almost analyse everthing.. there's no info in the Build.log..

For us, it would be intresting if u , or anyone else here, have/had the same problem .. we wouldnt asked ..if the problem is trivial rather visible in what u want to sent you.

Thx 4 Reply !

best regards,
Omi
Attached Images
 
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 10:09 AM.


Copyright 1999-2019 Kinook Software, Inc.