Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-26-2005, 09:25 PM
Ken Ken is online now
Registered User
 
Join Date: 05-08-2003
Posts: 20
Question Email with hyperlinks

I am tying to craft an email that has hyperlinks in for the engineers to travers over to so they can see there failures. Its something like this. I am using the email feature on VBP.

Dear Sir,
The nightly build failed and you were identified as one engineers who changed this file. The data log can be found at

http:\\MyCompany.com\logfile%LOG_ID%

Where LOG_ID is a macro that contains a string. However, when I attempt to do this, the hyplerlink does not appear to have the correct attributes.


Also, How do I put carrige returns in the mail, I don't seem to be able to do this.
Reply With Quote
  #2  
Old 07-27-2005, 07:45 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
Attached is a sample Send Mail step to send an HTML formatted message containing a URL. HTML browsers ignore whitespace and newlines in a web page, you have to use HTML formatting such as <p></p> or <br> to insert newlines that will be displayed.
Attached Files
File Type: bld mail.bld (688 Bytes, 504 views)
Reply With Quote
  #3  
Old 12-05-2006, 11:04 PM
GoldenBoy GoldenBoy is online now
Registered User
 
Join Date: 12-05-2006
Posts: 1
Do you have answer for the % in link paprt?

Hi,

You haven't answer the question were i need to use
parameter (%some_param%) in a hyper link

I'm using an <a href .. http://www.somelink.com%param% />

with the parameter added all mails sent having a wrong
address without the %param% the link is good

how can i solve this

Edi
Reply With Quote
  #4  
Old 12-06-2006, 12:17 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
There's nothing special about including a macro's value in the URL; its value will be expanded before being inserted. Please ZIP and send or post:
1) The info from Help | About | Install Info
2) A reproducible test case (.bld file that can be built here and reproduces the problem)
3) A build log file

Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:28 PM.


Copyright 1999-2019 Kinook Software, Inc.