Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Frequently Asked Questions > Troubleshooting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 12-18-2008, 11:00 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,643
Preventing hanging builds

Some users have reported problems with Visual Build sometimes hanging during a build, usually with long-running builds in a virtual machine guest when the Visual Build GUI application is launched from a scheduled task. One of the following ended up resolving the problem for different users who reported it:

1) Make sure that you have the latest version of Visual Build installed.

2) Uncheck Tools | User Options | Display | Automatically refresh panes during build.

3) Make sure that Tools | Application Options | Advanced | Maximum step output macro length is not set to 0 and is less than 10,000,000 (the default is 1,048,576).

4) Build with the console app instead of the GUI app.

5) Increase the amount of RAM on the machine and/or VM guest.

6) Stop anti-virus software on the build machine or add an exclusion for Visual Build to its active scanning.

7) Add the /mta command-line flag to all calls to VisBuildPro/VisBuildCmd. In a VisBuildPro Project action, add /mta to the Additional options field on the Parameters tab.



In a few cases, users reported that the build completes but the VisBuildCmd.exe process does not exit, particularly when called from continuous integration tools such as CruiseControl.NET or Jenkins. A possible workaround in this case would be to add a Kill Process action at the end of the project to terminate the build process ([Builder.ProcessID]).


In some cases, it wasn't Visual Build itself that hung, but a program called by Visual Build (for instance, msdev.exe) that was never completing. This is likely the case if the build can still be aborted in Visual Build (it is just waiting for the process to complete). In these situations, one of the following often rectified the problem:

1) Disable multiple core CPU functionality in the BIOS.

2) Ensure the problem program runs with processor affinity to a single core/CPU. On the Advanced tab of the step that runs the problem program, specify a single CPU/core (i.e., 1 for the first) in the Affinity field.

3) Configure the step to terminate after some amount of time (More tab).


If none of the above helps, send the info from http://www.kinook.com/Forum/showthre...?threadid=3044.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:32 PM.


Copyright 1999-2019 Kinook Software, Inc.