Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-08-2016, 11:44 AM
lockedude lockedude is online now
Registered User
 
Join Date: 09-07-2011
Posts: 10
Write XML and create element formatting

I am using the Write XML action to a dynamic number of elements to a config file. AS always, VBP is working great as expected except for the resulting format of the config file after adding elements. No LF or CR are being applied after the elements. For example:

Initial:
<connectionStrings>
<add name="ConnectionString1"/>
</connectionStrings>

After adding additional elements:
<connectionStrings>
<add name="ConnectionString1"/>
<add name="ConnectionString2"/><add name="ConnectionString3"/><add name="ConnectionString4"/></connectionStrings>

Admittedly, the file is stil valid from an XML standpoint, but it becomes very unreadable when the elements may contain large amounts of information.

I have tried various things to no avail. Is there anyway to add a CR\LF after adding an element?
Reply With Quote
  #2  
Old 03-09-2016, 07:45 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,753
You can format the XML document after updating using the Transform XML Log action.
http://kinook.com/VisBuildPro/Manual...mlogaction.htm
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 11:18 AM.


Copyright 1999-2019 Kinook Software, Inc.