Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-05-2009, 01:10 PM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
Copying Items Between Databases Doesn't Bring Custom Attributes Properly

Perhaps I'm expecting something extraordinary. When I copy template items with custom attributes and forms based on those attributes, the custom attributes don't follow properly and the form row that contained those attributes are empty.

The help says that all of this shouldn't be a problem. Is there an approach to inducing the correct behaviour?
Reply With Quote
  #2  
Old 06-05-2009, 03:04 PM
quant's Avatar
quant quant is online now
Registered User
 
Join Date: 11-30-2006
Posts: 967
works as expected here, can't think of the reason why that wouldn't work ...
Reply With Quote
  #3  
Old 06-05-2009, 03:22 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
That works ok in our tests (tested by copying some books from the Books.urd sample to a new database).
Reply With Quote
  #4  
Old 06-07-2009, 10:36 AM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
Unhappy

Sigh.

I've never actually seen the feature function as expected. I just now did it again, and it fails exactly as I describe.

I drag a new template I've created, based on the document template with new attributes and a custom form that includes those attributes. The template item in the target database is missing some (not all) of the new attributes and the form is different because of the missing attributes.

So, I've attached a tiny version of the source database that I've been using. If any of you can drag the template item "Research Document", in tact, with all attributes and the form, into a new empty database, I'll have to be surprised.
Attached Files
File Type: zip empty_tsse.zip (75.6 KB, 697 views)
Reply With Quote
  #5  
Old 06-07-2009, 10:44 AM
quant's Avatar
quant quant is online now
Registered User
 
Join Date: 11-30-2006
Posts: 967
confirmed, the attributes are there, but the form is incorrect.
Reply With Quote
  #6  
Old 06-07-2009, 01:34 PM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
for sure all attributes? "Cited" and "significance" and "research reference" appear to be there, but "Value", "Analysed" and "Publication" attributes don't appear in the target.
Reply With Quote
  #7  
Old 06-07-2009, 02:24 PM
quant's Avatar
quant quant is online now
Registered User
 
Join Date: 11-30-2006
Posts: 967
ok, I found the most probable reason for your problem.

The form contains attributes that "Research Reference" does not, hence the problem ...
Reply With Quote
  #8  
Old 06-07-2009, 04:40 PM
TimP TimP is online now
Registered User
 
Join Date: 01-31-2006
Location: I live in a small village a few minutes south of Ottawa, Canada
Posts: 58
Smile

Nice call! And thanks for taking the trouble to understand this problem. UltraRecall and its excellent user community strike again!

So, forms do not carry attributes to items they're assigned to. I can certainly see both sides of the discussion that might ensue from this. However, I would definitely side with those who think a form carried around by a template should carry its attributes into derived items instead of their just sort of floating in the form.

I hope Kinook will figure out how to deal with this. The help page titled "Form" under "Getting Started > Basic Concepts > Attribute > Attribute Type >" states that a form is an alternate method "for viewing and editing the item's attributes." I've had a good look around, and nowhere is there a mention of attributes having to be assigned to an item before a form can be used in such a manner. As much as there's a warning that attributes could be lost when changing the template of an item, I would think that a similar caution about the comings and goings of forms would be equally helpful.
Reply With Quote
  #9  
Old 06-07-2009, 04:55 PM
quant's Avatar
quant quant is online now
Registered User
 
Join Date: 11-30-2006
Posts: 967
Quote:
Originally posted by TimP
However, I would definitely side with those who think a form carried around by a template should carry its attributes into derived items instead of their just sort of floating in the form.
form in only a frontend, so I believe Kinook will fix this oversight so that set of form "attributes" is neccessary subset of the set of template's attributes (or alternativelly automatically add the new ones to the set of template's attributes).
Reply With Quote
  #10  
Old 06-08-2009, 10:38 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
Yes, at this time, you do need to add all form attributes to the template in order for inter-db copy to include all form attributes.
Reply With Quote
  #11  
Old 12-30-2009, 02:02 PM
goggin goggin is online now
Registered User
 
Join Date: 07-26-2008
Posts: 15
Is this why when I copy the Journal Year template from the provided sample file and paste it into my practice db, it doesn't work as advertised?

That is, highlighting a given month and hitting insert is supposed to produce a Journal child item with today's date as the title, but instead I get a text child item.

I get item attributes (i'm pretty sure, anyway), but don't get the role the "form" plays in the discussions above...that's why I'm not sure I've understood this thread correctly. And I definitely don't know what is meant by "copying form attributes to a template."

Thx in advance for the help...
--
dg
Reply With Quote
  #12  
Old 12-31-2009, 09:02 AM
ashwken ashwken is offline
Registered User
 
Join Date: 10-16-2005
Location: Blairsville, GA USA
Posts: 431
Quote:
Originally posted by goggin
Is this why when I copy the Journal Year template from the provided sample file and paste it into my practice db, it doesn't work as advertised?

That is, highlighting a given month and hitting insert is supposed to produce a Journal child item with today's date as the title, but instead I get a text child item.

I get item attributes (i'm pretty sure, anyway), but don't get the role the "form" plays in the discussions above...that's why I'm not sure I've understood this thread correctly. And I definitely don't know what is meant by "copying form attributes to a template."

Thx in advance for the help...
--
dg
Apparently the Templates are losing the Default Child Attribute value when copied to the new database.

At first I copied the Year Template to a New db, which produced it self, plus its child Templates (Month, Journal Entry), plus it created a second Month Template. The creation of the individual Month and Journal Entry Templates is to be expected since they reside as children of the Year Template, but the creation of the second Month Template is strange. Shift-Delete all copied Templates.

Next, I copied just the Journal Entry Template, then the Month Template, then the Year Template. In this case the Month Template did not duplicate, but the Default Child Template value is lost.

Next, I copied some Templates from one of my db with the same results, the Default Child Template value is lost.

Other Attributes values are retained (Icon, Form, Title Expression).

Running UR v.3.5e.
Reply With Quote
  #13  
Old 01-02-2010, 07:05 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
This is fixed in the latest download (UltraRecall.exe version 4.1.2.4 in Help | About | Install Info). Thanks.
Reply With Quote
  #14  
Old 01-02-2010, 08:00 PM
goggin goggin is online now
Registered User
 
Join Date: 07-26-2008
Posts: 15
Thank you! Once again, your responsiveness is amazing...and appreciated.
--
dg
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 09:13 AM.


Copyright 1999-2019 Kinook Software, Inc.