Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-12-2006, 07:41 PM
tfj tfj is online now
Registered User
 
Join Date: 01-29-2006
Posts: 19
Font Wierdness

I have hundreds of text items with data that is displayed in Gentium font (a unicode). Everything was OK until I changed my RICHED20.DLL to a previous version (as instructed by Kinook) so I could right-click in Item Notes.

The right-click now works perfectly, but as I said, now the fonts in all the items are screwed up. For some reason Tahoma font is interspersed with the Gentium font. If I select all and change to Genium, no problem. But when I leave the item and come back, again I see Genium fonts mixed up with Tahoma fonts!

Any ideas or suggestions?
Reply With Quote
  #2  
Old 07-13-2006, 08:39 AM
kevina kevina is online now
Registered User
 
Join Date: 03-26-2003
Posts: 825
Hmm, we've never encountered anything like what you describe. I did just download and install the Gentium font you mention, but can't reproduce the reported behaviour.

What OS, SP, versions of Office, and related do you have installed? What version of the Gentium font do you have installed (it appears it is still in a form of "beta").

If you search for riched20.dll on your system (dir riched20.dll /s at c:\ from a command prompt), what different versions of this dll do you have? If you have multiple versions installed in various places, you might try the others (copy them one at a time to the Ultra Recall installation folder) to see if one of them resolves both issues (the context menu issue as well as the Gentium font issue).

Another trouble-shooting option would be to copy a couple affected info items to a new .urd file, then post that file here or email it to support@kinook.com for our review.
Reply With Quote
  #3  
Old 07-13-2006, 09:25 AM
tfj tfj is online now
Registered User
 
Join Date: 01-29-2006
Posts: 19
FONT WOES

I am attaching a jpeg so you can get an idea of what I am babbling about.

The red font is Tahoma (the XP default font?), and the black font is Gentium, which is the way all the Greek appeared before I fiddled with the dll. For some reason some of the Greek letters appear as big ugly Tahoma fonts.

Is there any way I can turn off or disable the Tahoma in UltraRecall so everything is Gentium? Probably not.

I am at a loss of what to do, though I will as you recommend fiddle some more with the other dlls and see what happens.
Attached Images
 
Reply With Quote
  #4  
Old 07-13-2006, 11:39 AM
tfj tfj is online now
Registered User
 
Join Date: 01-29-2006
Posts: 19
Oh, well...

I switched to the v. 6.0 12.0.4017.1003 dll, and the Gentium font returned to normal, but then I lost the right-click feature again. Oh, well, I guess that's the tradeoff, and it's tolerable, but maybe something could be done about this dll problem in the future? Just wondering.
Reply With Quote
  #5  
Old 07-13-2006, 09:55 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,607
Hopefully MS will fix the right-click issue before the final release of Office 2007 (which I believe is where that version of riched20.dll comes from).
Reply With Quote
  #6  
Old 07-13-2006, 10:09 PM
tfj tfj is online now
Registered User
 
Join Date: 01-29-2006
Posts: 19
Give MS a Push

Could you somehow tell MS that their darn DLL is the culprit? As if they would care. Once again we are at MS's mercy, I guess.
Reply With Quote
  #7  
Old 07-18-2006, 03:01 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,607
We found a workaround for the issues w/ context menu display for the riched20.dll from the Office 2007 beta. Download and install http://www.kinook.com/Download/UltraRecallProTest.exe to try it.
Reply With Quote
  #8  
Old 07-18-2006, 06:18 PM
tfj tfj is online now
Registered User
 
Join Date: 01-29-2006
Posts: 19
Well Done!

It works like a charm! Thanks, Kinook. UR is the best.
Reply With Quote
  #9  
Old 10-09-2007, 11:21 AM
tfjern tfjern is online now
Registered User
 
Join Date: 10-09-2007
Posts: 132
Unicode Problem Again

Greetings! This problem was solved quickly and skillfully by the Kinook staff once before (the problem was discussed in the thread unicode "Font Wierdness" posted last year), but after getting a new computer I am having a problem with unicode Greek fonts not appearing as they should in the items panes (they appear in English alphabet).

In the past I was told to fiddle with the files riched20.dll (several are installed, for example there's one in the windows/system32 folder and one in the Office 12 folder).

In the previous thread mentioned above I was told to download this file:

http://www.kinook.com/Download/UltraRecallProTest.exe

but the link is no longer working.

Is there any way I could get this download, or has it been replaced but something else?

I am using UltraRecall Professional 3.2

Thanks
Reply With Quote
  #10  
Old 10-09-2007, 11:43 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,607
All UR builds since that test build include the fix for the context menu problem w/ the Office 2007 beta riched20.dll. Based on the problem reported last year, it appears you should try using the Office 2007 riched20.dll with UR (hopefully it still works like the 2007 beta DLL [which apparently is what you were using then] for your problem).
http://www.kinook.com/Forum/showthre...?threadid=2853
Reply With Quote
  #11  
Old 10-10-2007, 02:26 AM
tfjern tfjern is online now
Registered User
 
Join Date: 10-09-2007
Posts: 132
MS Office 2007's riched20.dll

Once again Kinook's sincere and professional online assistence is one of the best of any software company I know of, but it appears the culprit is the riched20.dll that came with Office 2007 (version 6.0 -- 12.0.4518.1014), which apparently replaced the one that came with the Office 2007 beta (it worked well with the unifonts when I tried it in UR 2.0 last year).

The only other riched20.dll on my system is in c:\WINDOWS/system 32, version 3.0 -- 5.30.23.1228, which I also tried in the UR path but it didn't work.

I'm sure this is entirely a Microsoft problem (what else would be new?), but if you happen to come up with a workaround please let me know.

Thanks.
Reply With Quote
  #12  
Old 10-10-2007, 10:19 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,607
Can you ZIP and send a .urd file with one of these problem items to support@kinook.com for us to look at? Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 04:26 PM.


Copyright 1999-2019 Kinook Software, Inc.