Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-27-2018, 05:50 AM
reflex reflex is online now
Registered User
 
Join Date: 01-16-2014
Posts: 7
Code signing doesn't work - can't find file

I'm using Visual Build Pro 9.6 (x64).

I can't build any projects that have code signing anymore. The error message is:
Code:
27/06/2018 11:40:32: Building project step 13 - Sign binaries...
Processing file 3 of 4: w:\dev\flstudio\Plugins\Fruity\Effects\Fruity Convolver\FruityPlug.dll
27/06/2018 11:40:32: Building project step 14 - Sign (SHA256)...
Verifying signature...
Failed to create process: The system cannot find the file specified.
27/06/2018 11:40:32: Step '14 - Sign (SHA256)' failed
27/06/2018 11:40:32: Build ended (elapsed = 00:00:32).
The file that has to be signed is present in the indicated location (it's built by the project).

As far as I can tell, this started after installing Visual Studio 2017 Community Edition, so I have the impression that Visual Build Pro has a problem locating signtool.

I have looked for signtool.exe and it appears in various locations. See the image at this url for a list:
https://www.dropbox.com/s/zv2hgxxnrl...ntool.PNG?dl=0

What can I do to make sure Visual Build Pro finds signtool? Is there any way to get more information about this error?
Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:45 PM.


Copyright 1999-2019 Kinook Software, Inc.