Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-08-2014, 10:20 AM
pclancey pclancey is online now
Registered User
 
Join Date: 04-08-2014
Posts: 4
Wait for files hangs if files aren't there

Part of my build involves waiting for the executables and dlls to appear in an Output directory after code signing. I'm using Wait Until... Files(s) are created or modified, but this step continues to wait even after the files appear.

If I simply stop the script, and re-execute the step, then I get the message:
"All file(s) already exist, continuing without waiting", and the script continues on. This tells me my file list is correct.

I am using v8.6 under Win7, this script was imported from v6.7 (WinXP), where it used to work.

Any ideas?
Reply With Quote
  #2  
Old 04-08-2014, 11:32 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
Not sure. It's working as expected here. I tested with the attached scripts, starting wait.bld, and then when create.bld is built, the wait.bld project completes.

http://www.kinook.com/Forum/showthread.php?t=3044
Attached Files
File Type: zip test.zip (773 Bytes, 576 views)
Reply With Quote
  #3  
Old 04-08-2014, 01:52 PM
pclancey pclancey is online now
Registered User
 
Join Date: 04-08-2014
Posts: 4
You're correct, your test files do work.

Please see post below for the results of further testing...

Last edited by pclancey; 04-08-2014 at 02:57 PM. Reason: Testing has brought new information to light
Reply With Quote
  #4  
Old 04-08-2014, 02:55 PM
pclancey pclancey is online now
Registered User
 
Join Date: 04-08-2014
Posts: 4
I have now determined that when:

1. VBP is Waiting for the files to be created in the networked folder
2. CodeSigning moves the desired files in - Wait does not trigger
3. Any change to the networked folder will trigger the Wait to see the code signed files and complete - for example, if I drop in a random, unrelated file, or even if I delete the files it is waiting for

It would seem that the way that the corporate CodeSigning program moves the files into the directory does not trigger the Wait, but any other change to the directory does.

Again, this used to work in VBP 6.7 / WinXP, with the same corporate CodeSigning mechanism.
Reply With Quote
  #5  
Old 04-09-2014, 12:02 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,754
The FindFirstChangeNotification API (used by the Wait action in all versions of Visual Build) can have problems with network shares (see http://support.microsoft.com/kb/188321). Perhaps it was more reliable in Win XP?

You could always roll your own -- create a Loop step that waits forever, and in the loop an Exit step to exit the loop, configured to pause for a few seconds and a build rule to execute only if the file you're looking for exists ([vbld_FSO.FileExists("%FILENAME%)].
Reply With Quote
  #6  
Old 04-09-2014, 11:13 AM
pclancey pclancey is online now
Registered User
 
Join Date: 04-08-2014
Posts: 4
That is what I will do - thanks very much for your help.
Reply With Quote
Reply

Tags
wait

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:28 AM.


Copyright 1999-2019 Kinook Software, Inc.