Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-13-2021, 01:56 AM
Spliff Spliff is online now
Registered User
 
Join Date: 04-07-2021
Posts: 65
Problem: "Link" icons even for just copied items

Copies of items get a "linked" item icon (as in real links) which is not what I want, so I searched for a way to stop this - but perhaps it's not possible currently? Btw, that in fact somewhat changed item icon, in "Item Attributes" though, remains (in my cases) the regular "Text" icon, so it doesn't seem to be possible even to manually change the "linked" text icon from within the "Item Attributes" pane, back to the "regular" text icon, except by creating another item and then manually assigning that (not tried)?

Also, since in the "Item Attributes" pane, the "linked" icon is listed as the "regular" icon, it's not even possible to search for those "linked" icons, then replace them with some additional icon in bulk.

Is there any way currently to avoid this behavior when copying items / inserting those copies into the tree? I understand that in some use cases, even copies may be linked to the "original" item, but more often than not, such a link is not even wanted.

The only way I found is copying (^c) the "original" item to another (!) database, then moving it back to the original database (^x over there, then ^v here), but that obviously is no realistic way to do it, again and again.
Reply With Quote
  #2  
Old 06-13-2021, 10:55 AM
Spliff Spliff is online now
Registered User
 
Join Date: 04-07-2021
Posts: 65
Similar problem with LINKED Items

READ HERE FIRST (second edit):

MY MISTAKE, sorry. Logical fault of mine. The "Link" sub-symbol for Links do disappear after I also empty the deleted copy, or the deleted original, from the Recyle Bin.


This one really is annoying: When I have item A, then LINK to item B (i.e. creating virtual item Aa), both items' icons get the "link" sub-symbol, to indicate "is an item with at least 2 parents (1 original parent, and at least 1 virtual parent)".

When I then delete item Aa, the "link" sub-symbol stays in item A's icon, and when I (in another example) delete item A, the "link" sub-symbol stays in item Aa's icon.

"View - Refresh" does not help; closing the database and re-opening it does not help; Tools - Compact and Repair does not help.

Thus, upon deletion of an item, and probably also upon moving (not only copying) it to another database, there may be no sub-routine checking if the item in question has exactly two parents, so that by deletion or "moving out", the remaining icon should be reset to "regular", i.e. without the "link" sub-symbol.

This is a glitch not even in my main database (see "Reasonable database sizes"), but also in my secondary databases (about 25,000 items) which had not been affected by the import and then deletion of 50,000 items to a base of 70,000 ones.


Considering that now, after cut (^x), the icons don't get greyed-out in my secondary databases (as described above; see "Tree problems and suggestions" z) over there) either, the icon problem(s) described here may have for cause some recent problem with my UR exe (?), so that on other systems, everything, or at least the icons' "link" symbol being deleted when they have become obsolete, may work as expected?

EDIT: Just re-installed UR, problems of this thread persist even in secondary databases. (Problem of icon not being greyed-out after ^x only persists in main database, affected by the intermediate "reasonable database size" excess; will need to create new database for that, then import 75,000 items...)

Last edited by Spliff; 06-13-2021 at 11:37 AM.
Reply With Quote
  #3  
Old 06-14-2021, 03:16 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,815
You should duplicate (Copy, Edit | Paste Special | Duplicate) rather than logically linking (copy/paste) if you don't want an item to display as logically linked.

https://kinook.com/UltraRecall/Manua...callinking.htm

To remove logically linked instances, use Shift+Delete.
Reply With Quote
  #4  
Old 06-22-2021, 12:46 PM
Spliff Spliff is online now
Registered User
 
Join Date: 04-07-2021
Posts: 65
Thank you so much, Kyle, that works: ^c as usual, then "Duplicate" (put on another shortkey, +^y instead of just ^y in my case).
Reply With Quote
Reply

Tags
icons , links

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:40 PM.


Copyright 1999-2021 Kinook Software, Inc.