Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-09-2008, 03:42 AM
DuncanL DuncanL is offline
Registered User
 
Join Date: 07-26-2007
Posts: 29
Actions finding MSBuild.exe

How is MSBuild located by the Make VS.NET/2005 actions?

On a new setup my VS2005 projects are failing to build. If I override the default handling by pointing to the actual location (C:\Windows\Microsoft.NET\Framework\v2.0.50727\MSB uild.exe) then it works, but removing that and relying on the detection fails.

Any suggestions? Thanks.

Last edited by DuncanL; 04-09-2008 at 05:24 AM.
Reply With Quote
  #2  
Old 04-09-2008, 09:00 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,612
It looks for the registry value HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k\InstallRoot, then iterates over all subdirectories of the folder in that registry value for the newest framework version (excluding v3.0 since it doesn't include msbuild.exe), and using the dir+msbuild.exe if found.

Please ZIP and send to support@kinook.com or post:
1) The info from Help | About | Install Info
2) The .bld file
3) A build log file
4) The .sln file and project files (no source code files)
5) Export of registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k
6) Recursive directory listing of .NET Framework path (i.e., dir /s C:\WINDOWS\Microsoft.NET\Framework\ > out.txt from a Command Prompt)

Thanks.
Reply With Quote
  #3  
Old 04-09-2008, 09:41 AM
DuncanL DuncanL is offline
Registered User
 
Join Date: 07-26-2007
Posts: 29
Very odd... unless I'm going blind it all looks OK. I will e-mail you the requested information.
Reply With Quote
  #4  
Old 04-09-2008, 11:24 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,612
The problem is that on your system, there is a v3.5 subfolder with no msbuild.exe in it (which is normally the case if .NET 3.5 has been installed). Either delete/move that folder or install VBP v6.7 -- one of the changes in 6.7 is to use msbuild.exe from .NET v2.0 for building VS2005 solutions even if .NET v3.5 is detected.
Reply With Quote
  #5  
Old 04-10-2008, 05:35 AM
DuncanL DuncanL is offline
Registered User
 
Join Date: 07-26-2007
Posts: 29
Thank you very much. For now we have just removed the folder. If we need .NET 3.5 in the future then we will have to update VBP.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:57 AM.


Copyright 1999-2019 Kinook Software, Inc.