Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-09-2019, 10:25 AM
karelt karelt is online now
Registered User
 
Join Date: 05-23-2016
Posts: 30
Exclamation Error when inserting child item via tear-off toolbar

Hi,
haven't seen a better place to report a bug. If there is, kindly correct me.

concerning:
Toolbar/Tree/Insert Child
Toolbar/Tree/Insert Sibling

bug:
when their menus are teared off and docked, sometimes, the buttons don't add the appropriate child/sibling. Instead they set on adding only one item type no matter what button is pressed (the type choice changes).
The wrong item inserted really has the wrong type. It's not just a wrong icon. Also the Item type does not correct itself upon restart.
When I insert the appropriate child/sibling using either RMB menu over item in the tree or using the Toolbar/Tree/Insert Child or Toolbar/Tree/Insert Sibling, the error disappears.
When Sibling toolbar worked, Child did not, closed child toolbar, created new child toolbar. The new child toolbar works, but now the sibling toolbar produces the bug.
Undocking the toolbar does not change the status of which toolbar produces a bug.

suspected source of the bug:
it seems to me that the simultaneous existence of both child and sibling toolbars
or the simultaneous existence of their buttons (when buttons from both toolbar are transferred to another toolbar)
is what starts the bug.


example:
UR restart
insert sibling folder via toolbar button inserts folder
insert sibling text via toolbar button inserts text ... it works
insert child folder via toolbar button inserts folder
insert child text via toolbar button inserts folder ... bug
insert child text via tree/item RMB menu OR Toolbar/Tree/Insert Child/insert text insert texts
insert child text via toolbar button inserts folder ... works

Any idea?
Best,
K

Last edited by karelt; 02-09-2019 at 10:52 AM.
Reply With Quote
  #2  
Old 02-10-2019, 06:18 PM
karelt karelt is online now
Registered User
 
Join Date: 05-23-2016
Posts: 30
update:
Just created a folder (e.g. "X") and moved all items such as Appointments, Recycle Bin, etc there so they are out of my way. Moved this folder to be at the bottom of the item tree. Then changed its icon. Then moved to the folders with text notes above. Selected one item and tried to insert a text child item using a button from the Tree/Insert child menu, that I dragged to my custom toolbar.
This created a symbolic link of the folder X at the bottom of the item tree.
Undo worked.
Tried again. Same result.
After typing this text, went there to try it again and the error stopped repeating itself and the toolbar buttons appear to work correctly.

k
Reply With Quote
  #3  
Old 02-10-2019, 07:14 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,550
I was able to reproduce the error when clicking an item on the tear-off Insert Child toolbar, will investigate.
Reply With Quote
Reply

Tags
bug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 06:08 PM.


Copyright 1999-2019 Kinook Software, Inc.