Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-17-2010, 08:49 AM
mikeg mikeg is online now
Registered User
 
Join Date: 09-19-2007
Posts: 106
"Minimizing updates to the database" FAQ

Is the FAQ "Minimizing updates to the database (single-user mode)" up-to-date and valid for URp 4.x on Windows 7 x64?

I downloaded multiusermode.zip, closed UR, ran (merged) DisableMultiUserMode.reg and confirmed existance of the key/value using Regedit. Next, I started UR, looked for Tools | Options | Miscellaneous, Delay, but there is no Delay option (at least not in URp 4.2). Finally, I set "Tools | Options | Editor | Auto-save changes every x minutes" to 15.

Despite these actions and even closing/starting UR a second time, the database is still being updated every 60 seconds when open and not in use.

FAQ: http://www.kinook.com/Forum/showthre...+AND+multiuser
Reply With Quote
  #2  
Old 11-17-2010, 10:40 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
Re: "Minimizing updates to the database" FAQ

Quote:
Originally posted by mikeg
Is the FAQ "Minimizing updates to the database (single-user mode)" up-to-date and valid for URp 4.x on Windows 7 x64?
Yes -- testing on Win7 x64, I disabled multi-user mode and access date updates, restarted UR, opened a database, and waited 30 minutes. The Date modified timestamp on the .urd file did not change.
Quote:
I downloaded multiusermode.zip, closed UR, ran (merged) DisableMultiUserMode.reg and confirmed existance of the key/value using Regedit. Next, I started UR, looked for Tools | Options | Miscellaneous, Delay, but there is no Delay option (at least not in URp 4.2). Finally, I set "Tools | Options | Editor | Auto-save changes every x minutes" to 15.
This option was moved to the Trees (More) tab in 4.2 -- I've updated the FAQ for this. But changing the option value in the GUI was not actually updating this setting -- this is fixed in the latest download (4.2.0.5).
Quote:
Despite these actions and even closing/starting UR a second time, the database is still being updated every 60 seconds when open and not in use.

FAQ: http://www.kinook.com/Forum/showthre...+AND+multiuser
Maybe try restarting Windows to make sure UR is fully restarted.
Reply With Quote
  #3  
Old 11-19-2010, 05:00 PM
mikeg mikeg is online now
Registered User
 
Join Date: 09-19-2007
Posts: 106
Thanks for the quick assistance and 4.2.0.5 update. I should explain why I'm using this FAQ.

I keep seperate UR databases for home and work. The remote database is only there for reference/backup purposes. I keep the home and work UR folders synced with online storage and with each other (currently using Windows Live Mesh). (BTW, this is why I wish UR had an internal per-database read-only option instead of having to change the file itself to R/O--which would be problematic in this 2-way sync scenario.)

Anyway, with SingleUserMode already enabled, I installed 4.2.0.5, rebooted, started UR, and tried everything from leaving "Delay before updating item access date" at the default 4000 milliseconds to setting this and auto-save changes to 0 (and restarting). Live Mesh continues to re-sync every 10 seconds as long as an UR database is open.

Before I made all these changes I observed re-sync approx. every 30 seconds, so it's actually getting worse! The modified datetime is not changing, so I don't know what is making Live Mesh, Sugar Sync, etc. go crazy when it comes to UR.
Reply With Quote
  #4  
Old 11-19-2010, 06:07 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,757
I don't see any reason why sync apps would think the .urd file has changed when open in UR if single-user mode is enabled, but we'll add to our list to do some testing w/ Live Mesh, and also consider providing a way to open the database read-only even if the file itself is writeable.
Reply With Quote
  #5  
Old 11-19-2010, 08:59 PM
mikeg mikeg is online now
Registered User
 
Join Date: 09-19-2007
Posts: 106
Thank you. I'm gonna throw Process Explorer at it this weekend and see if I find anything useful.
Reply With Quote
  #6  
Old 11-24-2010, 08:20 AM
mikeg mikeg is online now
Registered User
 
Join Date: 09-19-2007
Posts: 106
I'm no expert at using Process Explorer, but I can see recurring I/O activity in the Read and Other section. No activity in the Write section after initial startup. (See screenshot. The second monitor window was captured a minute or two after the first.)

A very tiny amount of data is involved each time--16 bytes in this case. I've seen up to 48 bytes in PE views of Live Mesh. Yes, it triggers sync approx. every 10-30 seconds, but perhaps this isn't enough data to be worth bothering with?

Whatever you decide, I hope we can at least have UR read-only database mode at some point. There are many cases where I'd like to open a databases read-only to avoid accidental updates (without having to change the file attribute) and have one or more open in normal read/write mode at the same time.

----------------------------------------------
P.S. I noticed my last post was #100 which finally clicked me over to "Senior Member" after all these years. I don't know whether to expect balloons and party whistles or a walker with a big white bow on it, LOL!
Attached Images
 

Last edited by mikeg; 11-24-2010 at 03:02 PM.
Reply With Quote
  #7  
Old 04-09-2011, 12:40 AM
mikeg mikeg is online now
Registered User
 
Join Date: 09-19-2007
Posts: 106
After living with this issue for several months, I would say adding capability to open an UR database in virtual read-only mode while the underlying file is writable is definitely more important than figuring out how to stop what turned out to be tiny amounts of data (probably polling) when syncing files with Windows Live Mesh.

My scheme with home, work and laptop (travel) UR databases sync'ed up to all three locations works fine as long as I don't open the two "remote" files. The moment I open a remote DB in UR I get a location_(computerName).urd shadow copy synced to all 3 locations which quickly becomes a mess.

Hope you can fit "open and search DB's in virtual read-only mode" somewhere in the already packed road-map.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:24 PM.


Copyright 1999-2019 Kinook Software, Inc.