Thread: VBP is freezing
View Single Post
  #1  
Old 07-13-2012, 09:20 AM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 182
VBP is freezing

I used to have this problem on another machine (http://kinook.com/Forum/showthread.php?t=3888) but now it appears on a new machine (OS installed approx 1 month ago)
Basically the build remains frozen at some random steps (run program,send email,zip files),nothing is written in the log anymore,when I look in Task Mgr I see the VBP process and the child process if it is the case (e.g msbuild.exe) ,by killing the child process the build still remains frozen.
Usually the builds are ran through VisBuildCmd.exe silently from Scheduled Tasks,I tried even to lunch them by VisuildPro with usei interface -in this case I got a white screen and process appears as not responding (see the attachment).
I tried to reproduce this issue but it still appears randomly,not every time.
However I noticed the build freeze appears only when I have multiple (3-4) builds running in the same time (from different folders).
In this case -1 or 2 builds remains frozen always ,the rest are finished ok.
But the necessary build time is increased quite substantial,the builds are very slow-maybe this is causing the freeze ,not sure.
It is important to solve this issue as it happened we had to do some urgent build and when checked if finished -it appears as still running because it was frozen.
I implemented the steps from here:
http://www.kinook.com/Forum/showthre...?threadid=3892
but did not help.
Even if the hanging step is configured to finish after some time -this does not happen ,it still remains frozen.
This machine is Win2k8 X64 ,4 GB of RAM ,Intel Xeon 3320@2.50 Ghz 2.49 Ghz
VBP installed is :
Visual Build Professional 8.0 (x64)
I created even some dump file for frozen VBP process,I can send it to you if you think it is needed.
Regards
Attached Images
   
Reply With Quote