View Single Post
Old 05-24-2021, 05:18 AM
Spliff Spliff is online now
Registered User
Join Date: 04-07-2021
Posts: 85
Re the above-mentioned "Unknown File - File Identifier - By - Search" problem:

Web research showed that that tool had been installed together with "File Viewer Lite", which I use perhaps once a year and which is free.

So I de-installed this "File Identifier" tool (without problem, and "File Viewer Lite" is legitimate, too), then tried again, in UR, "New Tab" - the problems have nothing to do with a shortkey which may interfere (^t here, and which may trigger something outside UR) since I use the menu: "Tab - New Tab".

Now that the "File Identifier" tool is gone, I get, in the very same situation, i.e. by "Tab - New Tab", the original Windows file dialog (!): "You'll need a new app to open this about link - Look for an app in the Microsoft Store - [checkbox automaticatlly checked:] Always use this app" btut with the "OK" button greyed out, so here, I have to click on "Look for an app in the Microsoft Store" in order to get rid of the dialog (it opens another MS window telling me there is no application for this, and then I can manually close that second MS window - EDIT for clarification: this second MS window is "Microsoft Store - Results for 'about' - No results for this filtering" - no idea what this "about" may be, but this detail probably helps?), whilst with the proprietary "File Identifier" tool, I was at least able to close that first dialog already.

I did NOT get into this situation when by the context menu in the tree ("Data Explorer"), I do "Open in new tab", this worked as expected.

Then, I tried, again by context menu, "Open document", and here, the item was opened in my rtf tool (which in my case is Atlantis Word Processor, I don't use MS Word 2016 but very exceptionally), and further tries with "Open document" brought "Click here to continue editing stored content externally / Click here to resume internal editing".

I never use external editing though, normally (except for trying this out now).

From the above, I deduct that perhaps the file dialogs (be them the proprietary tool or then the "original" MS Windows dialog) when I do "Tab - New Tab" MAY be connected with UR's functionality to allow for external editing, and this alternative MAY be triggered by "Tab - New Tab", and then the Windows system does obviously NOT know what to do, externally, with an UR tab = a whole tree within the running UR application window?


- No macro tool or similar running which could cause this.

- The "point of departure" for (the non-problematic) "Context menu - Open in new tab" is a SINGLE item, whilst the "point of departure" for (the problematic) "Tab - New Tab" is unspecified and thus may be processed, by the command, as "whole tree", thus probably Windows not knowing what to do with it, but Windows obviously gets the order to "have a look upon it", this "look into it" hint for Windows obviously is redundant since the processing, in ANY situation, i.e. even if the user regularly opens items = single "documents" externally, the "new tab" will necessarily be created within UR

- If the problem can NOT be identified, the way around obviously is "Open in new tab", on a single item, to create a new tab, where, as said, the problem doesn't appear

Last edited by Spliff; 05-24-2021 at 06:13 AM.
Reply With Quote