View Single Post
  #1  
Old 06-12-2012, 02:21 PM
bwilder bwilder is online now
Registered User
 
Join Date: 02-23-2011
Posts: 17
Cannot get psexec to work with vbp8

Hi,
I'm trying to create a build farm using VBP8. Right now I'm specifically trying to spawn of a separate child process on a remote machine and I'm having little to no luck at all.

1. Both machines are 64 bit Windows 7 ultimate machines,
2. Both machines have VBP 8 installed,
3. Both machines have the installation path for VBP in the %PATH% env variable,
4. Both machines have psexec.exe v.1.98 installed in c:\windows\system32, which is also in %PATH%,
5. I have 2 VBP scripts with 1 step each,
a. Script1 is on machine1 and its only step is supposed to kick off the VBP script on machine2,
b. Script2 is on machine2 and its only step is a "Create Folder" to create c:\BTESTFOLDER on machine2.
6. When I run the following command from the command line on machine1, I get the successful results below: "psexec \\machine2 VisBuildCmd.exe /nooutput c:\BuildFolder\BuildScripts\Script2.bld":

Code:
RRProdBuild\BuildScripts\Test1.bld PsExec v1.98 - Execute processes remotely Copyright (C) 2001-2010 Mark Russinovich Sysinternals - www.sysinternals.com VisBuildCmd (x64), Version 8.0.0.3 Copyright (C) 1999-2012 Kinook Software, Inc. All rights reserved. Registered to: Tencent Boston, Inc. (2-computer license) VisBuildCmd.exe exited on machine2 with error code 0.
7. When I attempt to achieve the same results with a VisBuildPro Project step in script 1, I get the following response:

Code:
6/12/2012 2:13:43 PM: -------------------- Starting Build: 'TEST.bld' -------------------- 6/12/2012 2:13:43 PM: Building project step 2 - VisBuildPro Project... C:\Windows\system32\cmd.exe /C PsExec -d >C:\Users\MACH~1.TEN\AppData\Local\Temp\PsE4E6C.tmp -u tbuild -p ********** \\MACHINE2 "C:\Program Files\VisBuildPro8\VisBuildCmd.exe" /b TEST1.bld 2>&1 'PsExec' is not recognized as an internal or external command, operable program or batch file. Process completed with exit code 1
I get this same response when I attempt to run the command line string from step 6 in either a "Run Program" or "Batch File" step in VBP and this is where I'm stuck. From where here it looks like VBP cannot find psexec even though it's in the %PATH% and clearly available to the command line.

Any thoughts on how I should troubleshoot further?
Reply With Quote