View Single Post
  #1  
Old 12-12-2007, 02:42 PM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 182
'Rename files' step fails

I have one step producing file addedResults.xml by applying some styles with msxsl.exe.
This is followed by another step-renaming addedResults.xml to an existent results.xml(I chose option to delete the existent files if found).
Until today everything was ok but from 10 am (strange it started precisely at this hour :-) ) this step continously fails:
//*************
Output of the step was:
Renaming files in 'D:\Reports\BuildsOutput\2007.1212.1.0\'...
Deleting results.xml
addedResults.xml -> results.xml
The process cannot access the file because it is being used by another process.
//*************
Is there any possiblity to rename this file even if it is in use?
I did not discover yet what process is using this file,I tried with FileMon but box frozen.
But after the build process finished I tried manually to rename that file and it was ok,so only during the build it is reported as in use.
Reply With Quote