View Single Post
Old 08-23-2018, 09:13 AM
scoffman scoffman is online now
Registered User
Join Date: 08-22-2018
Posts: 3
I had domain\username in the web.config, which worked until the script hit Perforce. I took your suggestion and modified the code and attempted a variety of different scenarios. Unfortunately, none of the changes eliminated the error with Perforce.

I tried and passing null as the domain parameter. When doing so, I wasn't able to connect to the weblauncher. When I revert back to domain\username, I am able to connect to the weblauncher.

As I had been attempting to use a domain user, I decided to try a local user. So I created a local user and made the user an admin. I passed the credentials for the local user. And I was able to bypass the Perforce error.

It would appear to be an issue with CreateProcessWithLogonW and Perforce using a domain user.

I did come across an article from a few years ago that described a similar situation. One poster mentioned the user might not have access to the share, even if the same credentials are passed.
Reply With Quote