Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   When Importing ... (

tfj 02-09-2006 05:40 PM

When Importing ...
When importing a list of items in order to have them quickly inserted as Nodes on a Tree (e.g., by inserting paragraphs as Childs), I was wondering if this can be done in UR. Let's say the rtf file to be imported looks like this:

01_snake 54
02_cat 43
03_dog 5555
04_fish 4322
05_bird 12

and so on (notice the spaces after the words and before the numbers ).

Now when the rtf file is imported, the Delimiter Info is paragraphs, and UR imports the five paragraphs without any problem (that is, there will appear five new nodes on the tree)., However, there any way to have the nodes end at the space, that is, before the numbers (54, 43, etc.), which will appear instead in the Item Details and not in the Nodes? And is it also possible to do something so the initial items (e.g., 01_snake) is not repeated in the Item Details window? So it will look something like this (I hope the formatting doesn't get mixed up after posting):

Data Explorer Item Details
01_snake 54
02_cat 43
03_dog 5555
04_fish 4322
05_bird 12

and NOT like this

Data Explorer Item Details
01_snake 54 01_snake 54
02_cat 43 02_cat 43
03_dog 5555 03_dog 5555
04_fish 4322 04_fish 4322
05_bird 12 05_bird 12

which is what happens when the paragraphs are imported.

tfj 02-09-2006 05:43 PM

As feared the spaces were removed between the imported paragraphs when I posted my last post -- e.g., 01_bird 54 in the Data Explorer, and it repeated exactly in Item Details. Sigh!

kevina 02-10-2006 12:44 PM

There isn't a way to have Ultra Recall determine the indent level based on leading spaces or tabs, but another option does exist (it will only work with plain text however):

Save your indent level, title, and text values in a csv file, in the following format, then use the Import Wizard to import a delimited text file (.csv):

"Indent Level","Item Title","Item Text" <- this is a header row (optional)
0,02_cat,43 <-not indented
1,03_dog,5555 <- indented one level

... etc

When importing, ensure you "map" the appropriate csv columns to the "Item Title", "Item Text" and "Indent Level" attributes. This will happen automatically if you include a header file similar to what I provided above.

Note: the <- ??? are comments and should not be included in the actual csv you create and import

tfj 02-10-2006 06:26 PM

Works Like a Charm
Thanks. It worked perfectly. UR rocks!

All times are GMT -5. The time now is 10:55 PM.

Copyright 1999-2019 Kinook Software, Inc.