Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Error creating custom action 'Make VS.NET': Class not registered (http://www.kinook.com/Forum/showthread.php?t=2908)

John Gardner 08-13-2007 10:17 AM

Error creating custom action 'Make VS.NET': Class not registered
 
1 Attachment(s)
Hello, I am having a problem with 6.4 that I didn't have with 5.7

Background: VS6, VS 2003, VS 2005 Installed. .net framework 1.1 (& SDK) 2.0 (&SDK) 3.0 (redistributable only). All patched to the hilt. All old beta versions removed from registry and deleted from harddisk.

I downloaded testvs.bld. I get the same error:

Error creating custom action 'Make VS.NET': Class not registered

I ran regmon and filtered "visbuildpro". I launched visbuildpro (6.4) and started build. Regmon captured everything and then I saved it and zipped it (attached).

I have repaired .net framework 2.0 & SDK , reintalled VS 2003 and reinstalled .netframework 1.1

I need help because I am stuck. I have read other posts to this forum and tried what they have tried and so far, nothing has worked.

kinook 08-13-2007 10:29 AM

Please ZIP and send or post:
1) The info from Help | About | Install Info
2) The .bld file
3) A build log file
4) The .sln file and project files (no source code files)

Thanks.

John Gardner 08-13-2007 10:53 AM

Here tis
 
1 Attachment(s)
Visual Build Professional 6.4
Registered to: MICRO SYSTEMS ENGINEERING - LAKE OSWEGO, OR (1-site license)
Windows Version: 5.1.2600.2.0
Install path: C:\Program Files\VisBuildPro6
cmax20u.dll version 2.1.0.21
SftTree_IX86_U_50.dll version 5.06
unins000.exe version 51.15.0.0
unins001.exe version 51.46.0.0
VisBuildBld.dll version 5.7.0.0
VisBuildCmd.exe version 6.4.0.2
VisBuildCore.dll version 5.7.0.1
VisBuildDotNET.dll version 5.7.0.2
VisBuildExt.dll version 5.7.0.2

Log:

8/13/2007 8:43:46 AM: --------------------Starting Build: 'C:\testvs.bld'--------------------
8/13/2007 8:43:46 AM: Building project step 'Make VS.NET'...
Error creating custom action 'Make VS.NET': Class not registered
8/13/2007 8:44:04 AM: Step 'Make VS.NET' failed
8/13/2007 8:44:07 AM: Build ended.


:/ Ooh I think I see the problem. But I have installed 6.4 twice why did it not update / register 6.4 dlls in place of 5.7? This looks like an installer bug to me.

Yes I still have 5.7 installed (to handle older builds). They are installed in separate folders. I am a bit afraid to uninstall it because I'm not sure I could get the 5.7 release if I needed to.

Attached is the build file. I did not include solutions or projects simply because this build file fails. If the build file succeeded and my solution failed then I would send you that stuff too.

I'll wait for your reply before I attempt to uninstall 5.7 test and subsequently install 6.4 (third time) test and if that doesn't work uninstall 6.4 and then reinstall. Hurry with a reply. I tend to be very impatient :)

kinook 08-13-2007 11:09 AM

It looks like there are some v5 components in the v6 install path. That could definitely cause problems. v6 and v5 can be installed side-by-side (in different locations). I recommend uninstalling v5 and v6, deleting all VBP installation paths if still existing, and reinstalling v5, then v6, in different locations (the defaults are PF\VisBuildPro and PF\VisBuildPro6).

John Gardner 08-13-2007 11:12 AM

Thanks!
 
You guys are fast! Keep up the good work.

I noticed the 5 stuff. I don't know if I have the 5.7 download anymore so I may not be able to reinstall it. Can you give me a link to it?

But IMO, this looks like an installer issue to me.

Anyway, will do! I suspect this will solve all problems.

kinook 08-13-2007 11:21 AM

http://www.kinook.com/Download/VisBuildPro57.exe

In our testing, the v5/v6 installers work as expected, defaulting to distinct paths (but they don't prevent the user from installing both to the same path).

John Gardner 08-13-2007 12:15 PM

Looks like this addressed _ still think installer issue though
 
I think the installer should handle the situation where the user installs over an old build (same folder)

It either should:
1. Handle it.
2. Offer to uninstall previous version
3. Warn the user.

But you should not end up with a non-functional install.

BTW, when re-installing I got the defualt paths but when I initially installed 6.4 it came up with the old install path for 5.7

But I am up and running now. So thanks.


All times are GMT -5. The time now is 03:09 PM.


Copyright 1999-2019 Kinook Software, Inc.