Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   Error importing text file: Invalid parameter (

cnewtonne 07-25-2020 09:06 AM

Error importing text file: Invalid parameter
1 Attachment(s)
Hi all ...

I'm able to import the file if I move it to, for example, c:\testfolder, but the path as shown in the error message, is not liked by UR.

I guess it is having issues with this folder name 'sysdiagnose_2020.07.18_08-31-44-0400_nsurlsessionid'

What character is it not liking?


kinook 07-25-2020 12:07 PM

2 Attachment(s)
That worked in my test. If it worked in another folder, the file content wouldn't seem to be the issue. Please send or post the info from

cnewtonne 07-27-2020 08:01 AM

1 Attachment(s)
I think it has to do with the file size. If it is zero, I get 'invalid parameter' error. This is a test case ...

1. Created a file nice-zero.bat of zero bytes.
2. Right-click on an info item, import , got the error.
3. Created a second file nice.bat of 1kb. Imported successfully.

Sometime when I import folders, I have no control or prior knowledge of zero-byte files. In my case, I got too many 'invalid parameter' error.

Not sure why UR is having issues importing zero-byte files. If there is a programmatic constraint, then it would be nice to produce a more informative error message e.g. 'invalid parameter: file is zero bytes'


cnewtonne 07-27-2020 08:03 AM

Ultra Recall Professional 6.0 (x64)
Copyright 2004-2019 Kinook Software, Inc.
Registered to: xxxxx(1-user license)
Windows version: Windows 10 Home
Install path: C:\Program Files\UltraRecall
HRW15.DLL version
HTW21.DLL version 21,0,0,0
msptls.dll version 15.0.4420.1017
msvcr100.dll version 10.00.40219.325
PolarSpellChecker.dll version
riched20.dll version 15.0.4420.1017
SftPrintPreview_x64_U_20.dll version 2.07
TEW26.DLL version
UltraRecall.exe version
unins000.exe version
Database filename: C:\Users\xxxx\Dropbox\FollowMe\xxxx_UltraRecallDB\ Active\xxxGTD.urd
Database version: 4.0.1 [FTS]

kinook 07-27-2020 12:51 PM

That is a bug. Fixed in v6.1.

All times are GMT -5. The time now is 09:33 PM.

Copyright 1999-2019 Kinook Software, Inc.