Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] General Discussion (http://www.kinook.com/Forum/forumdisplay.php?f=2)
-   -   Failed to Create Empty Document (http://www.kinook.com/Forum/showthread.php?t=90)

gaz 05-05-2003 08:52 AM

Failed to Create Empty Document
 
I'm getting this error when Visual Build Pro runs on NT4 SP6a running IE 6. The old Visual Build (non-pro version) works fine. Any help would be greatly appreciated.

BethM 05-06-2003 01:07 PM

I think I have run into the same thing. I just attempted to install the latest version after purchasing a license - version 5.0. I saw the same error, and traced it to the permissions on the VisBuildPro.macros xml file. For some reason it only grants access rights to the users group. My login account is a member of the administrators group, and so was unable to open it. If you find the same situation, make sure you give rights to your login group. (I haven't actually tried this yet, as I have a bit of a time constraint, so I just reverted back to the previous version for now.)

Hope this helps.

Does Kinook have anything to say about this??

kinook 05-06-2003 02:26 PM

During installation, full rights are granted to the Users group on the common application data folder (\Application Data\Kinook Software\Visual Build Professional) when it is created. Normally, the Administrators group will already have full rights to the 'all users profile' directory, but not regular users. The admin group's rights should automatically propagate to this new subfolder as well (at least that's what happened in our testing). I'm not sure why it's not working that way in your cases.

gaz 05-07-2003 09:10 AM

Thanks for the suggestion, but no luck yet. I did noticed that it was installed on a FAT drive, thereby not providing a security tab to change permissions. I put it on an NTFS drive (on the same machine) but still no luck. Any other takers?

kinook 05-08-2003 08:16 AM

Yeah, I think BethM may have been experiencing a different problem. You definitely don't have a permissions issue if your system drive is FAT. And the global macros file gets loaded much later in the startup process than where the 'empty document' error would typically occur.

I'm a little baffled on what could be causing this problem. It's happening very early in the startup process in some plumbing code for the framework we're using (MFC). Is the problem occurring on multiple NT boxes or just a particular one? We'll probably need to take this offline and try a debug build in order to resolve it.

vrep 05-19-2003 09:20 AM

I have the same problem. Windows NT SP6a, IE6 en NTFS. Is there any progression in this problem? Or is the advice: "upgrade to Win2k"?

Thanks.

kinook 05-19-2003 10:33 AM

No success yet (nobody seems to want to debug it further). What are the size/version/date of the following files in your \System32 folder?

riched32.dll
riched20.dll

Can you give any more details about your configuration (other installed apps, OS/IE updates)?

vrep 05-19-2003 10:39 AM

riched32.dll is version 5.0.1458.47 (Product Version 5.0)
riched20.dll is version 5.30.23.1200 (Product Version 3.0)
IE is version 6.0.2800.1106 (SP1)
OS is version NT 4.0 with SP6a (4.00.1381)

Installed is amongst others:
MS Office97
MS Office2000
MS Visual Studio 6.0
Norton Antivirus 7.01

gaz 05-19-2003 10:42 AM

Here's what I got...

NT 4.0 SP6a

IE verion 6.0.2800.1106 with the following updates
Sp1;Q813489;Q330994;Q313829

riched20.dll version 5.30.23.1200
riched32.dll version 4.0.993.4

Other major apps includeVisual Studio 6.0, SourceSafe and ActiveState Perl

Feel free to email me directly if you'd like me to try a debug version on my setup.

kinook 05-19-2003 03:02 PM

We were able to reproduce the problem by installing Office 2000 on our virtual machine (thanks for the info). We believe we have a fix -- you can try it by downloading www.kinook.com/Download/VisBuildPro.zip and unzipping to your VisBuildPro installation path. Let me know if it does the trick.

gaz 05-19-2003 03:07 PM

Looks like that did it! Thanks for the help.

vrep 05-20-2003 07:35 AM

Yep, success here! Thank you very much for the effort.

Paddy Green 10-26-2003 08:15 PM

I have this problem with VisBuildPro 5.0
 
Was unable to download the file from the previous URL.

Can it be updated please.

Paddy Green 10-27-2003 03:49 AM

Everyone can stopping rushing around trying to help me now!!
 
I downloaded 5.0 again from the ftp.kinook.com site and reinstalled on the NT box and lo and behold it works.
It appears that the install exe has been updated (even though there is nothing listed in the release notes and no update email sent).
So im all happy now. Thanks everyone for the help.


All times are GMT -5. The time now is 01:25 AM.


Copyright 1999-2019 Kinook Software, Inc.