Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   VSphere usage (http://www.kinook.com/Forum/showthread.php?t=4962)

avijit 02-10-2012 07:07 AM

VSphere usage
 
Hi, I am new to VBP and need to know the usage of VSphere step. I have metioned the ESX server name, user, password but still when i am trying to power on a VM i am getting the 'The specified datastore is invalid' error. I can understand that there is some issue with the VM path that i have provided but i am not sure what i path it should be. I can access the VMWare ESX server using the VSphere client installed in my system and using the client i am see the VM path as [datastore1] WinXP_tmp\WinXP_tmpl.vmx. But when i am mentioning this as the VM path then i am always getting the same error. I need some help urgently. Thanks.

kinook 02-10-2012 07:43 AM

You need to double bracket [[ ]] characters in Visual Build fields.
http://www.kinook.com/VisBuildPro/Ma...ecialchars.htm

phaneendar 04-18-2013 12:13 AM

Not able to start / stop virtual machine on ESX server using vSphere
 
Hi, I am new to VBP(i use VBP7.7a) and need to know the usage of VSphere step. I have metioned the ESX server name (given IP), user, password but still when i am trying to power on a VM i am getting the 'Unable to connect to host. The specific version was not found' error. I can access the VMWare ESX server using the VSphere client installed in my system.The following are the details filled by me
VMware Tab:
Virtual machine: [[ESX2-DS1]] W2k8-R2-V2\W2k8-R2-V2.vmx
gave the OS user name and password and all other fields were blank.
Server Tab:
Host: gave the host IP address here
Host type: ESX/ESXi
port is blank and gave username and password

when i run the program i get the following error:
18-Apr-13 10:41:20 AM: -------------------- Starting Build: 'TestBuild.bld' --------------------
18-Apr-13 10:41:21 AM: Building project step 10 - VMware vSphere...
Unable to connect to host.
Error: The specified version was not found


. I need some help urgently. Thanks.

kinook 04-18-2013 07:01 AM

The error is coming from VMware's vmrun utility (http://www.vmware.com/support/developer/vix-api/). You would need to contact VMware regarding support for their product (when submitting support information to them, checking the Log command-line option on the Advanced tab of the action, rebuilding the step, and including the command-line syntax used may be helpful).

phaneendar 04-18-2013 07:05 AM

Thanks for the reply.
I got the problem resolved.
We need to install VMware VIX for VSphere API to work.
I installed the VMware VIX and every thing is working.


All times are GMT -5. The time now is 04:45 PM.


Copyright 1999-2019 Kinook Software, Inc.