Kinook Software Forums

Kinook Software Forums (
-   [VBP] General Discussion (
-   -   PowerShell remote (

HippyCraig 08-27-2015 10:50 AM

PowerShell remote
I am having trouble just doing a simple DIR from powershell on a remote server, its just sits there, I looked at the server and I can see a process started but it does nothing.

If I run the same on the local machine its fine.

please help!

HippyCraig 08-27-2015 11:28 AM

I do have the option to Show Application Window checked.

Before it would just hang there at
Starting C:\Windows\System32\WindowsPowerShell\v1.0\powersh ell.exe on USSBYAPPM8

I went to the server and set PS to unrestricted and then test and back again to restricted and now it displays

Starting C:\Windows\System32\WindowsPowerShell\v1.0\powersh ell.exe on USSBYAPPM8
AuthorizationManager check failed.
At line:1 char:2
+ & <<<< \\\c$\Sample.ps1
+ CategoryInfo : NotSpecified: (:) [], PSSecurityException
+ FullyQualifiedErrorId : RuntimeException


kinook 08-27-2015 11:37 AM

Please send the info from

HippyCraig 08-27-2015 11:47 AM

VB Version
PSExec 2.11

kinook 08-27-2015 11:52 AM

Please send or post the .bld file and log file.

HippyCraig 08-27-2015 12:23 PM

1 Attachment(s)
see attached, I removed the account info

kinook 08-27-2015 12:54 PM

What version+SP+bitness of Windows on the local machine and remote machine?

HippyCraig 08-27-2015 12:56 PM

Both are 2008 R2 Standard SP1

kinook 08-27-2015 10:58 PM

This is fixed in the latest build (VisBuildPro.exe in Help | About after installing). There were two problems:

1) PowerShell didn't like the path to the temporary script specified as \\computer\c$\xyz.ps1 on the remote call -- this was changed to reference as C:\xyz.ps1 instead.

2) PowerShell doesn't exit when called remotely -- a 'None' option was added to the Input format field on the Options tab, which must be used for remote calls to PowerShell to avoid this (see here for details).

Also, you should be able to specify Remote Signed rather than Unrestricted for the Execution policy on the Options tab.

HippyCraig 08-28-2015 09:35 AM

I will give it a try. I have a custom action that I wrote in VS2010 FW 4.0, that I use in my scripts. If I update to Version 9, I want to update the custom action to VS2013, can I use FW 4.5.2 for my custom action with VB 9x?

kinook 08-28-2015 10:31 AM

Yes, that should work.

HippyCraig 08-28-2015 12:19 PM

So far so good the power shell is working now I will test the upgrade of my custom action later.

I did notice that from 2012 r2 to 2012 r2 I didnt change the setting none but still in v9 it worked.

kinook 08-28-2015 12:31 PM

Maybe that was fixed in PowerShell v4.

HippyCraig 08-31-2015 09:07 AM

I have upgraded to v9x and the Power Shell scripts are now working thanks.

I am seeing something unfamiliar with the new version. When I open a script without setting any breakpoints and close VB I see a .user file created. Whats that about?

kinook 08-31-2015 09:25 AM

In v9 by default, Visual Build remembers the previously selected steps when reopening a project (stored in the .user file). To prevent this, uncheck Tools | User Options | General | Remember selected steps when reopening projects. The .bld.user file will still be created if you set breakpoints in a project (same as with v8).

All times are GMT -5. The time now is 06:35 AM.

Copyright 1999-2019 Kinook Software, Inc.