Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] General Discussion (http://www.kinook.com/Forum/forumdisplay.php?f=2)
-   -   Copy Files action problem (http://www.kinook.com/Forum/showthread.php?t=1880)

miker 07-03-2006 04:51 PM

Copy Files action problem
 
Having a problem with the 'Copy Files' action. I have a directory with mode '700'. When I copy a file to the directory, the 'Copy Files' action changes the mode of the directory to '500'.

If I run the Microsoft copy command from a Command Prompt window the problem does not occur. Also, The problem does not occur if I run the 'Copy Files' action from Microsoft Windows 2000 5.00.2195 Service Pack 4 machine but does occur on a Microsoft Windows Server 2003 Enterprise Edition Service Pack 1 machine.

I'm running Visual Build 6.1. Nothing is checked in the Copy tab. In the Options tab the following are checked:

Log files and folders that are copied, moved, or purged
Copy files in restartable mode
Keep read-only attribute on copied file
Wait for share name to be...

Has anyone encountered this problem?

kinook 07-04-2006 06:04 PM

The Copy Files action will set a destination folder's attributes to match the source folder.

miker 07-05-2006 09:21 AM

Understood. Just a mention that if a destination folder in a ClearCase view becomes not writable, a 'rmview' will produce 'cleartool: Error: Unable to remove the snapshot view directory.' message.


All times are GMT -5. The time now is 02:58 AM.


Copyright 1999-2019 Kinook Software, Inc.