Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   How to force "FTP" action to work though proxy server? (http://www.kinook.com/Forum/showthread.php?t=614)

Mike-7 11-15-2004 03:58 AM

How to force "FTP" action to work though proxy server?
 
Is it posible? Our company uses proxy server for FTP, so I'm not able to use FTP action currently built into Visual Build Pro.

kinook 11-15-2004 10:25 AM

Did you try checking 'Use passive mode' and entering the proxy server's address in the Server field? What sort of proxy and FTP server are you connecting through/to?

Mike-7 11-15-2004 10:59 AM

Passive mode option wouldn't help.
I need to specify both FTP server and FTP proxy - just like you specify both names in Internet Explorer - you type FTP server name in address field and type FTP proxy server name in Tools | Internet Options | Connections, "LAN Settings" button, then "Advanced" button.

kinook 11-16-2004 09:53 AM

Here is a test build of the next release which includes FTP proxy support: http://www.kinook.com/Download/VisBuildProBeta.exe.

Mike-7 11-16-2004 02:37 PM

seems to be not working yet...
here is how I set it up:

FTP server: XXX.XXX.XXX.XXX (ip address of my FTP)
Port: 21
username, password - for my FTP server
passive mode - tried both, doesn't work too
Proxy Type: Login (tried others - Open, Site, etc - even worth - gives out - "cannot login" message)
Proxy Server: DNS name of my proxy server (BTW our proxy server is MS ISAS 2000). E.g.: proxy.hq.com
Proxy port: 80 (like it is in Internet Explorer settings)
Username: my NT user name in corporate domain (e.g. HQ\Chief)
Password: my NT account password
passive mode - looks like this option for proxy is completely ignored (??)

ftp://username:password@XXX.XXX.XXX.XXX:21/ works fine in internet explorer.

here is the log (actual IPs and names changed due to security reasons):
--------------------Starting Build: 'Untitled'--------------------
Building project step 'FTP'...
Connecting to FTP server 'XXX.XXX.XXX.XXX' on port 21
VISBUILDPRO 232031 0000 INF: started process 0x10C0 trace on 11-16-2004 23:20:31 [4.0.4000]
VISBUILDPRO 232031 0101 INF: gethostbyname("proxy.hq.com") returned 10.55.55.55 (proxy1.hq.com)
VISBUILDPRO 232031 0020 INF: socket(2, 1, 0) returned 1120
VISBUILDPRO 232031 0030 INF: ioctlsocket(1120, 0x8004667e, 0x2c4f424) returned 0
VISBUILDPRO 232031 0020 WRN: connect(1120, 10.55.55.55:80, 16) returned -1 [10035]
VISBUILDPRO 232031 0010 INF: select(64, 0x0, 0x2c4f428, 0x0, 10:0) returned 1
VISBUILDPRO 232031 0020 INF: ioctlsocket(1120, 0x8004667e, 0x2c4f424) returned 0
VISBUILDPRO 232041 10014 INF: select(64, 0x2c4f254, 0x0, 0x0, 10:0) returned 0
VISBUILDPRO 232041 0020 INF: closesocket(1120) returned 0
Error connecting to proxy server: The specified operation has timed out
Step 'FTP' failed
Build ended.

kinook 11-16-2004 07:08 PM

We'll have to do some investigating to see if/how to support that proxy server.

Mike-7 11-17-2004 03:46 AM

ok, plz reply to my post after you'll get this fixed.
I'll be glad to act as an additional QA guy :)

kinook 11-18-2004 08:27 PM

Here's the response from the vendor of the networking component we use for FTP:

The ISA Server doesn't implement an FTP proxy per se, only an HTTP proxy that also handles FTP requests. When you normally enter an ftp:// URL in IE, the browser will use FTP to retrieve the file. However, when you setup IE to use a proxy, that ftp:// URL is passed to the proxy server and the proxy performs the download and then returns the contents to the client. In that case, the browser actually sees it as an HTTP GET request. I know that sounds odd, but that's how it works.

In short, you don't need to use proxy settings in the FTP control with ISA Server, you just connect normally. However, presuming that ISA Server is your gateway and also acting as your firewall, you need to have it configured to allow outbound FTP connections and the control itself should be set to use passive mode transfers.

Mike-7 11-19-2004 03:41 AM

Allowed outbound FTP connections is not an option for our organization (our security department prohibits its). So please ask your vendor to provide support for ISA Server, or use a different vendor, or even consider developing your own code for FTP support (huh, in case when I'm not the only one who needs to use FTP in such way :). The problem is simple, at first glance - the IE supports ISA - why not to support it in Visual Builder?

Or maybe simplier solution would be to embed a support for 3rd party FTP client application (like reget), which provides support for ISA and invoke it through command line.


All times are GMT -5. The time now is 12:00 AM.


Copyright 1999-2019 Kinook Software, Inc.