Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   trying to execute a PSEXEC (http://www.kinook.com/Forum/showthread.php?t=514)

VBuild_Rookie 07-19-2004 03:24 PM

trying to execute a PSEXEC
 
I can run this from the command prompt with no prob

psexec \\ustpaqaapp001 -u newtonqa\WebSvc -p syk3s*n6wt0n cscript "c:\windows\system32\iisweb.vbs" /stop "PGNewtonAdmin"


but can not run it from the visual build program and I am using the "RUN PROGRAM" tool

kevina 07-19-2004 03:33 PM

Please provide more detail on 'can't run' it from Visual Build Pro. The log entry corresponding to the failure would be very helpful in understanding what didn't work.

Is the error related to not finding the psexec app? If so, the simplest solution is to use an absolute path to the executable you are invoking...

VBuild_Rookie 07-19-2004 03:37 PM

Connecting to OLD_SERVER... Starting PsExec service on OLD_SERVER... Connecting with PsExec service on OLD_SERVER... Starting cscript on OLD_SERVER...
cscript exited on OLD_SERVER with error code -2147024664.

Process completed with exit code -2147024664
Step 'Stop Web Site' failed

kevina 07-19-2004 05:27 PM

Not sure, it works here with this simple test of psexec on a remote WinXP machine located on a different NT domain.

Attached is the build file and the test script I ran with it. [You'll have to change the computername, user and password values from *** to run it]

A reproduceable case would be helpful for troubleshooting. I can only guess that it is some sort of rights issue, but I certainly don't know for sure...

VBuild_Rookie 07-20-2004 09:35 AM

I could not see the attachment ..where is it here on the post or email I looked in both places

kevina 07-20-2004 09:43 AM

1 Attachment(s)
Oops, after reviewing my post, I didn't attach the file again :-(

It should be attached to this post.

VBuild_Rookie 05-09-2005 11:22 AM

still having issues
 
Ok not sure if this thread is still active if not I will repost.....
Anyway I tried your test.bld with the test.vbs it worked find
so I replaced c:\Test.vbs with c:\Windows\System32\iisweb.vbs /stop "Administration"...just to see if I can stop the Admin web site on the local pc.....I got the same error that I have been getting

"Process completed with exit code -2147024664"

kinook 05-11-2005 08:53 AM

1 Attachment(s)
That is odd. In my testing, it succeeds the first time but fails with that error afterwards. One workaround is to redirect the command's output to a file and read the file output (instead of reading stdout). See the attached sample.


All times are GMT -5. The time now is 01:59 AM.


Copyright 1999-2019 Kinook Software, Inc.